Bug 147271 - texinfo package duplicates texi2pdf script from tetex
texinfo package duplicates texi2pdf script from tetex
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-05 18:52 EST by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.8-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-09 06:48:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-02-05 18:52:45 EST
Description of problem:

After current rawhide updates we have:

$ rpm -qlvf /usr/bin/texi2pdf | sed -n /bin.texi2pdf/s'/.*t  *//p'
538 Jan 19 03:33 /usr/bin/texi2pdf
660 Feb  3 10:09 /usr/bin/texi2pdf

where these two scripts differ really only by an identifying header
comment.

$ rpm -qf /usr/bin/texi2pdf
tetex-2.0.2-30
texinfo-4.8-1

If 'texi2pdf' is to be moved to 'texinfo' package then most likely
together with its manpage which, so far, shows only in a package
'tetex'.

Version-Release number of selected component (if applicable):
texinfo-4.8-1
Comment 1 Tim Waugh 2005-02-07 04:52:57 EST
Thanks.  Fixed in texinfo-4.8-2.
Comment 2 Vadim Nasardinov 2005-06-06 13:18:49 EDT
Tim,

Do you know what happened to /usr/bin/texi2pdf in tetex in FC4?  As of
texinfo-4.8-2, the texinfo package no longer ships texi2pdf.  However,
tetex doesn't ship it either:

 | $ rpm -q tetex
 | tetex-3.0-4
 | $ rpm -ql tetex | grep -c texi2pdf
 | 0

Neither do any of the tetex subpackages:

 | $ rpm -qa 'tetex*'
 | tetex-3.0-4
 | tetex-dvips-3.0-4
 | tetex-fonts-3.0-4
 | tetex-xdvi-3.0-4
 | tetex-latex-3.0-4
 | tetex-afm-3.0-4
 | $ ls -l /usr/bin/texi2pdf
 | ls: /usr/bin/texi2pdf: No such file or directory
Comment 3 Tim Waugh 2005-06-06 13:30:38 EDT
Nope.  I just assumed tetex was going to be shipping it.

Jindrich?
Comment 4 Jindrich Novy 2005-06-07 08:35:22 EDT
Yep, texi2pdf is not shipped with tetex package, even if the tetex-3 tarball
contains local copy of texinfo. We should prefer separation of packages such as
texinfo from tetex as texinfo is developed indenendently on teTeX. When I
include texi2dvi, texi2pdf and friends to tetex, we need no more a separate
texinfo package, what we don't want.

The best solution from my point of view is to include texi2pdf to texinfo
package also for the reason that not all teTeX users need texi* utilities.
Comment 5 Tim Waugh 2005-06-07 09:36:44 EDT
Okay, added back in.  Thanks.
Comment 6 Michal Jaegermann 2005-06-08 15:50:16 EDT
Hm, so after all this too and fro we eneded up with texi2pdf in texinfo-4.8-5
but /usr/share/man/man1/texi2pdf.1.gz, which used to be owned by tetex,
disappeared completely.  It seems that 'texinfo' package would be a logical
place for it too.
Comment 7 Jindrich Novy 2005-06-09 05:14:50 EDT
Michal, /usr/share/man/man1/texi2pdf.1.gz isn't used to be included in tetex
package actually. Note that this man page has never been included in teTeX-1 and
is no more in teTeX since the first release of tetex-3.0. There's no texi2pdf
man page in the upstream texinfo tarball, because texi2pdf simply calls texi2dvi
--pdf to do the job.

Tim, feel free to grab the texi2pdf man page from tetex-2.0.2 because there
won't be any conflicts between tetex and texinfo or let me know and I'll mail it
to you.
Comment 8 Tim Waugh 2005-06-09 06:48:16 EDT
Got it.
Comment 9 Michal Jaegermann 2005-06-09 11:45:41 EDT
> Michal, /usr/share/man/man1/texi2pdf.1.gz isn't used to be included in tetex

$ rpm -qf /usr/share/man/man1/texi2pdf.1.gz
tetex-2.0.2-21.3

At least for some versions of packaging (this is on FC3) the reality says
otherwise. :-)  /usr/bin/texi2pdf there is supplied by tetex-2.0.2-21.3 too.
You are correct the the current packages for upcoming FC4 do not include that
manpage.

Note You need to log in before you can comment on or make changes to this bug.