Bug 147282 - Mixer applet crash
Mixer applet crash
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Depends On:
  Show dependency treegraph
Reported: 2005-02-06 02:42 EST by Neil Paris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.9.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-10 03:22:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output of MENU_VERBOSE=1 gnome-menu-spec-test (581.22 KB, text/plain)
2005-02-07 10:52 EST, Neil Paris
no flags Details
stacktrace (6.28 KB, text/plain)
2005-02-07 13:12 EST, Neil Paris
no flags Details
stacktrace from gnome-volume-manager (1.93 KB, text/plain)
2005-02-07 15:42 EST, Neil Paris
no flags Details
one more stacktrace (3.45 KB, text/plain)
2005-02-07 19:32 EST, Neil Paris
no flags Details
bt from mixer-applet2 (2.97 KB, text/plain)
2005-02-08 11:41 EST, Neil Paris
no flags Details
test-gst.c (4.89 KB, text/plain)
2005-02-09 05:04 EST, Mark McLoughlin
no flags Details

  None (edit)
Description Neil Paris 2005-02-06 02:42:26 EST
Description of problem:
After installing the latest version of gnome, it is unuseable. When I try to
access a menu, it won't work at all--it's as if I didn't click on the menus at
all. At startup, I get an error (I don't remember it, but I will go look)

I can access nautilus, and I can run apps just fine from a terminal. (I do not
konw if this is a bug in gnome-menus or gnome-panels--or even something else)

I have included all the versions from 'yum list *gnome*'

Version-Release number of selected component (if applicable):
gnome-applets.x86_64                     1:2.9.5-2              installed
gnome-audio.noarch                       2.0.0-2                installed
gnome-audio-extra.noarch                 2.0.0-2                installed
gnome-bluetooth.x86_64                   0.5.1-8                installed
gnome-bluetooth-devel.x86_64             0.5.1-8                installed
gnome-bluetooth-libs.x86_64              0.5.1-8                installed
gnome-desktop.x86_64                        installed
gnome-desktop.i386                          installed
gnome-desktop-devel.x86_64                  installed
gnome-doc-utils.noarch                   0.1.2-2                installed
gnome-games.x86_64                       1:2.9.5-2              installed
gnome-icon-theme.noarch                  2.9.90-3               installed
gnome-kerberos.x86_64                    0.3.3-1                installed
gnome-keyring.x86_64                     0.4.1-1                installed
gnome-keyring.i386                       0.4.1-1                installed
gnome-keyring-devel.x86_64               0.4.1-1                installed
gnome-keyring-manager.x86_64             0.0.4-1                installed
gnome-libs.x86_64                        1:        installed
gnome-libs-devel.x86_64                  1:        installed
gnome-mag.i386                           0.11.13-1              installed
gnome-mag.x86_64                         0.11.13-1              installed
gnome-mag-devel.x86_64                   0.11.13-1              installed
gnome-media.x86_64                       2.9.90-1               installed
gnome-menus.x86_64                       2.9.90-2               installed
gnome-menus.i386                         2.9.90-2               installed
gnome-menus-devel.x86_64                 2.9.90-2               installed
gnome-mime-data.x86_64                   2.4.2-1                installed
gnome-netstatus.x86_64                   2.9.4-1                installed
gnome-nettool.x86_64                     0.99.3-2               installed
gnome-panel.i386                         2.9.90-3               installed
gnome-panel.x86_64                       2.9.90-3               installed
gnome-panel-devel.x86_64                 2.9.90-3               installed
gnome-pilot.x86_64                       2.0.12-4               installed
gnome-pilot-conduits.x86_64              2.0.12-3               installed
gnome-pilot-devel.x86_64                 2.0.12-4               installed
gnome-print.x86_64                       1:0.37-10              installed
gnome-print-devel.x86_64                 1:0.37-10              installed
gnome-python2.x86_64                     2.6.0-5                installed
gnome-python2-applet.x86_64              2.6.0-5                installed
gnome-python2-bonobo.x86_64              2.6.0-5                installed
gnome-python2-canvas.x86_64              2.6.0-5                installed
gnome-python2-gconf.x86_64               2.6.0-5                installed
gnome-python2-gnomeprint.x86_64          2.6.0-5                installed
gnome-python2-gnomevfs.x86_64            2.6.0-5                installed
gnome-python2-gtkhtml2.x86_64            2.6.0-5                installed
gnome-session.x86_64                     2.9.4-1                installed
gnome-speech.x86_64                      0.3.6-1                installed
gnome-speech.i386                        0.3.6-1                installed
gnome-speech-devel.x86_64                0.3.6-1                installed
gnome-spell.i386                         1.0.5-8                installed
gnome-spell.x86_64                       1.0.5-8                installed
gnome-system-monitor.x86_64              2.9.90-1               installed
gnome-terminal.x86_64                    2.9.2-1                installed
gnome-themes.x86_64                      2.9.90-3               installed
gnome-user-docs.noarch                   2.8.1-2                installed
gnome-utils.x86_64                       1:2.9.90-1             installed
gnome-vfs.x86_64                         1.0.5-21               installed
gnome-vfs-devel.x86_64                   1.0.5-21               installed
gnome-vfs-extras.x86_64                  0.2.0-9                installed
gnome-vfs2.x86_64                        2.9.90-1               installed
gnome-vfs2.i386                          2.9.90-1               installed
gnome-vfs2-devel.x86_64                  2.9.90-1               installed
gnome-vfs2-smb.x86_64                    2.9.90-1               installed
gnome-volume-manager.x86_64              1.1.0-5                installed
Comment 1 Mark McLoughlin 2005-02-07 04:34:29 EST

  - Do you have $XDG_DATA_DIRS or $XDG_CONFIG_DIRS set by any chance?
    (You shouldn't)

  - Do you have a ~/.config/menus/applications.menu ? What does it
    contain? If you move it aside, does it fix the problem?

  - What's the output of:

      $> MENU_VERBOSE=1 gnome-menu-spec-test

Comment 2 Neil Paris 2005-02-07 10:52:45 EST
Created attachment 110727 [details]
output of MENU_VERBOSE=1 gnome-menu-spec-test

Neither $XDG_DATA_DIRS nor $XDG_CONFIG_DIRS is set; also, I have no

I'll attach the output from MENU_VERBOSE=1 gnome-menu-spec-test, since it's
Comment 3 Mark McLoughlin 2005-02-07 11:17:05 EST

Accessories/	gnome-gcalctool.desktop	...
Accessories/	gnome-gucharmap.desktop	...

That means you should have menus.

You rebooted after upgrading at some point, right? You're not in the same
session since upgrading or anything?

Is the panel hung, maybe? Does right clicking on the panel do anything?
Comment 4 Neil Paris 2005-02-07 11:19:23 EST
I have rebooted, several times. I even removed gnome and reinstalled it (through
yum, that wasn't fun)

No, nothing happens when I click on the panel

(just a note, as I said earlier, I'm not sure if this is gnome-menus or
gnome-panel (or maybe something else))
Comment 5 Mark McLoughlin 2005-02-07 12:08:55 EST
Nothing happens when you *right* click on the panel ?
Comment 6 Neil Paris 2005-02-07 12:11:15 EST
(In reply to comment #5)
> Nothing happens when you *right* click on the panel ?

Nothing at all. In fact, the icons that were on the panel are gone now.

I can right click on the desktop just fine (that's how I got the terminal). I
*can* change Workspaces, minimize all the windows, and click between the windows.
Comment 7 Mark McLoughlin 2005-02-07 12:58:21 EST
Ah, its hung then. 

We'll need a stack trace to figure out where its hung. See:


You'll need to:

  1) Install gnome-panel, gnome-menus and gtk2 debuginfo RPMs
  2) Run bug-buddy, "Don't update", "Debug a crashed application", select
     "crashed application", put "/usr/bin/gnome-panel" in "Binary file" entry,
     the pid of gnome-panel in "Process ID" and click start
  3) Save the output by and attach it here.
Comment 8 Neil Paris 2005-02-07 13:12:16 EST
Created attachment 110735 [details]
Comment 9 Mark McLoughlin 2005-02-07 13:37:35 EST
It looks like an applet is hanging. Try doing "ps -ef" and see which applet was
the last one to be run and then getting a stack trace from that
Comment 10 Neil Paris 2005-02-07 15:42:25 EST
Created attachment 110752 [details]
stacktrace from gnome-volume-manager

I don't know if this is hanging, but it actually gave me a stack, so I figured
I'd post it here. Another thing I forgot to mention is that when I load gnome,
I get an error for "mixer_applet2" (related to gnome-volume-manager?)
Comment 11 Neil Paris 2005-02-07 19:32:24 EST
Created attachment 110768 [details]
one more stacktrace

Last one, I promise :)

After killing gnome-panel and restarting it, ps -ef shows 'wnck-applet', so I
got a stack from that, too. I hope I'm not just randomly finding stacktraces to
post here.
Comment 12 Ryan James 2005-02-08 01:12:22 EST
my panel doesn't freeze, but my applications menu is empty.  when you click on
it, it opens: turns blue, a box drops down to be filled with stuff, but the box
is only a couple pixels square.  if i drop a "main menu" thing (the hat w/ apps
& actions), it just shows the stuff from the actions menu in it. 
update-desktop-database returns:

[root localhost ~]# update-desktop-database -v
Search path is now:
[/usr/local/share/applications, /usr/share/applications]
File '/usr/local/share/applications/marlin.desktop' lacks MimeType key
File '/usr/local/share/applications/gnome-mud.desktop' lacks MimeType key
File '/usr/share/applications/xfce-panel-settings.desktop' lacks MimeType key
File '/usr/share/applications/redhat-evolution.desktop' lacks MimeType key
File '/usr/share/applications/gnome-default-applications.desktop' lacks MimeType key
File '/usr/share/applications/gnome-terminal.desktop' lacks MimeType key
File '/usr/share/applications/gnome-session-properties.desktop' lacks MimeType key
File '/usr/share/applications/gnome-devhelp.desktop' lacks MimeType key
File '/usr/share/applications/gnome-dasher.desktop' lacks MimeType key
File '/usr/share/applications/gnome-bug-buddy.desktop' lacks MimeType key 

i have gnome-menus vers. 2.9.90-2 and redhat-menus vers. 3.7.1-5, gnome-panel
vers. 2.8.1-9 (would be latest, but won't up2date due to balsa needing to be
rebuilt for some lib).  $XDG_DATA_DIRS and $XDG_CONFIG_DIRS are not set.

~/.config/menus/applications.menu contains:
<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
 <!-- File created by desktop-file-utils version 0.8 -->

/etc/xdg/menus/applications.menu has a bunch of stuff about pulling in
directories and some excludes.

i tried to run MENU_VERBOSE=1 gnome-menu-spec-test, but the command could not be
found (i tried as my normal user as as root).
Comment 13 Mark McLoughlin 2005-02-08 02:40:10 EST
Neil: there's nothing abnormal about either stack trace. Try getting stack
traces of any applet that's running from /usr/libexec and if any don't look like
the wncklet-applet one, then post that.

Ryan: your problem is that you've an old panel - the old panel doesn't know
about the new system.
Comment 14 Neil Paris 2005-02-08 03:32:08 EST
I couldn't find any particular stack traces to post here, so I tried another
route: I removed gnome-applets, and my menus work fine now.

What could this mean?
Comment 15 Mark McLoughlin 2005-02-08 03:41:04 EST
It means one of the applets in gnome-applets is broken. You could try re-install
gnome-applets and remove (from the panel) each of the applets in turn to figure
out which one it is.
Comment 16 Neil Paris 2005-02-08 03:46:34 EST
Will that work? If gnome-applets is what's causing the panel to freeze, I don't
see how I can remove applets from the panel.

I will gladly help if I can, though.
Comment 17 Mark McLoughlin 2005-02-08 03:57:30 EST
Heh, good point. You'll need to do it from the command line - e.g.

$> gconftool-2 -g /apps/panel/general/applet_id_list

then to remove the mixer you'd do

$> gconftool-2 -s /apps/panel/general/applet_id_list -t list --list-type string \

Now, gnome-panel contains the clock, show_desktop_button, window_list,
workspace_switcher and fish applets. So, none of them could be the problem. Try
removing any of the others one by one, though.

(Thanks for all this, we'll get there)
Comment 18 Neil Paris 2005-02-08 04:27:56 EST
Ok, well, I did:

gconftool-2 -s /apps/panel/general/applet_id_list -t list --list-type string \

And the dialog came up again saying "mixer_applet2 has quit unexpectedly".
Before running this command, the menus still worked. Now they're frozen again.
Also of note, when I uninstalled gnome-applets, it threw another error about the
mixer (I won't lie, I didn't pay much attention to it), and asked if I wanted to
remove it (? does that sound like something?), to which I said yes. After that,
everything worked fine.
Comment 19 Neil Paris 2005-02-08 04:30:25 EST
Sorry for the spam, but I removed gnome-applets again, did 'killall gnome-panel'
and got the dialog again. It says: 

The panel encountered a problem while loading "OAFIID:GNOME_MixerApplet".
Do you want to delete this applet from your configuration?

Delete makes everything ok again.
Comment 20 Mark McLoughlin 2005-02-08 05:28:18 EST
(The gconftool-2 command you ran isn't really what you wanted - it makes you
*only* have the mixer applet on your panel. gconftool-2 --recursive-unset
/apps/panel will get things back to the default if you want.)

So, the first error "mixer_applet2 has quit unexpectedly" shows that its a
problem with the mixer applet. Do this:

 1) Re-install gnome-applets

 2) gconftool-2 -s /apps/panel/general/applet_id_list -t list --list-type string

 3) log in, you'll get the error

 4) gnome-session-remove gnome-panel

 5) gdb /usr/libexec/mixer_applet2

 6) type "run"

 7) GNOME_PANEL_DEBUG=1 gnome-panel (from another terminal)

 8) I'd expect to see the mixer applet crash in gdb, then type 
    "thread apply bt all" and you should get a stack trace
Comment 21 Neil Paris 2005-02-08 11:41:36 EST
Created attachment 110809 [details]
bt from mixer-applet2

Ok, so I followed the steps as closely as I could. After doing
"gnome-session-remove gnome-panel", I don't know if I was supposed to kill it
myself or not, but it didn't go away, so I did end up killing it.
After "thread apply bt all", nothing happened, but then "bt" did provide me
with the stack (that I've attached)

I hope that I didn't mess it up.
Comment 22 Mark McLoughlin 2005-02-09 05:02:56 EST
Okay, pretty sure what's going on from looking at the stack trace and code.

Could you compile this test program and run it?

$> gcc $(pkg-config --cflags --libs gstreamer-interfaces-0.8) test-gst.c -o test-gst
$> ./test-gst
Name: Intel 82801DB-ICH4 (Alsa Mixer) (15 tracks)
Name: Analog Devices AD1981B (OSS Mixer) (11 tracks)
Comment 23 Mark McLoughlin 2005-02-09 05:04:01 EST
Created attachment 110862 [details]
Comment 24 Mark McLoughlin 2005-02-09 06:04:18 EST
Pretty sure this is the fix:


Just want to see the output from when you run test-gst first.
Comment 25 Mark McLoughlin 2005-02-09 07:02:24 EST
gnome-applets-2.5.3-3 is building at the moment with that fix. Could
you test that too ?
Comment 26 Neil Paris 2005-02-09 15:18:37 EST
./test-gst outputs:
Name: NVidia CK8S (Alsa Mixer) (21 tracks)
Name: C-Media Electronics CMI9761 (OSS Mixer) (12 tracks)

(In reply to comment #25)
> gnome-applets-2.5.3-3 is building at the moment with that fix. Could
> you test that too ?

Where do I get this? Will it be available through yum?
Comment 27 Mark McLoughlin 2005-02-09 15:56:57 EST
Hmm, that wasn't the output I was expecting to see :/

gnome-applets-2.9.6-1 will probably appear through yum tommorrow sometime. It
missed this morning's compose.

Actually, screw it - here they are :-)

Comment 28 Neil Paris 2005-02-09 16:15:09 EST
Mark...I think it works!

Installed Packages
gnome-applets.x86_64                     1:2.9.6-1              installed

No hang! I even rebooted. Now, I don't have to enable something to see if it
"really" works, do I?
Comment 29 Mark McLoughlin 2005-02-10 03:22:55 EST
As long as the mixer applet is on the panel and the panel is starting up without
hanging, then its fixed.

Thanks for all your help.

Note You need to log in before you can comment on or make changes to this bug.