This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 147285 - 5 * dead code detected
5 * dead code detected
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libgnomeprint22 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Kašík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-06 04:55 EST by David Binderman
Modified: 2008-04-01 09:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 09:49:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2005-02-06 04:55:35 EST
Description of problem:

I just tried to compile package libgnomeprint22-2.8.2-1 from 
Redhat Fedora development tree.

The compiler said

sft.c(234): remark #177: function "mkTag" was declared but never
referenced
sft.c(300): remark #177: function "PutInt16" was declared but never
referenced
ttcr.c(130): remark #177: function "GetInt32" was declared but never
referenced
ttcr.c(146): remark #177: function "GetUInt32" was declared but never
referenced
ttcr.c(212): remark #177: function "PutInt32" was declared but never
referenced

I've had a look at the source code, and I agree with the compiler.
Suggest delete dead code.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marek Kašík 2008-04-01 09:49:16 EDT
This is not a bug. These functions are there because of fullness of offered
functions.
Additionally, these functions have no negative impact on functionality of the
library.

  Marek Kasik

Note You need to log in before you can comment on or make changes to this bug.