This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1472850 - kernel: BUG: scheduling while atomic: rcuos/2/29/0x00000200
kernel: BUG: scheduling while atomic: rcuos/2/29/0x00000200
Status: CLOSED DUPLICATE of bug 1471459
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
26
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 10:08 EDT by vt
Modified: 2017-07-19 10:22 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 10:22:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vt 2017-07-19 10:08:03 EDT
Description of problem:

kernel reports error of 'BUG: scheduling while atomic: rcuos/2/29/0x00000200' some desktop apps (google-chrome) hang around this happens, but I'm not sure whether they're related, abrt can't catch the calltrace so it can't be reported via abrt. I can find the calltrace info from journal log. This happens almost for every boots, the system doesn't hang but some apps breaks, so I need to reboot my system to make it work.

Version-Release number of selected component (if applicable):

Fedora 26 workstation x86_64
kernel-4.11.9-300.fc26.x86_64


How reproducible:
90%

Steps to Reproduce:
1. Boot the system, play as usual and wait for it happens, sometimes it just happens during boot.

Actual results:

calltrace from journal log:

Jul 19 21:19:26 localhost kernel: BUG: scheduling while atomic: rcuos/2/29/0x00000200
Jul 19 21:19:26 localhost kernel: Modules linked in: acpi_call(OE) ccm rfcomm fuse tun br_netfilter ip_set nfnetlink bridge stp llc cmac bnep sunrpc vfat fat uvcv
Jul 19 21:19:26 localhost kernel:  tpm_tis soundcore shpchp tpm_tis_core i2c_i801 tpm intel_pch_thermal xfs libcrc32c i915 crc32c_intel i2c_algo_bit drm_kms_helpe
Jul 19 21:19:26 localhost kernel: CPU: 0 PID: 29 Comm: rcuos/2 Tainted: G           OE   4.11.9-300.fc26.x86_64 #1
Jul 19 21:19:26 localhost kernel: Hardware name: LENOVO 20BTS1N70F/20BTS1N70F, BIOS N14ET28W (1.06 ) 03/12/2015
Jul 19 21:19:26 localhost kernel: Call Trace:
Jul 19 21:19:26 localhost kernel:  dump_stack+0x63/0x84
Jul 19 21:19:26 localhost kernel:  __schedule_bug+0x55/0x70
Jul 19 21:19:26 localhost kernel:  __schedule+0x66e/0x8d0
Jul 19 21:19:26 localhost kernel:  schedule+0x36/0x80
Jul 19 21:19:26 localhost kernel:  schedule_timeout+0x202/0x300
Jul 19 21:19:26 localhost kernel:  ? account_entity_enqueue+0xd8/0x100
Jul 19 21:19:26 localhost kernel:  wait_for_completion+0x118/0x180
Jul 19 21:19:26 localhost kernel:  ? wait_for_completion+0x118/0x180
Jul 19 21:19:26 localhost kernel:  ? wake_up_q+0x80/0x80
Jul 19 21:19:26 localhost kernel:  __wait_rcu_gp+0xcc/0x100
Jul 19 21:19:26 localhost kernel:  synchronize_sched+0x5d/0x80
Jul 19 21:19:26 localhost kernel:  ? __call_rcu+0x310/0x310
Jul 19 21:19:26 localhost kernel:  ? trace_raw_output_rcu_utilization+0x60/0x60
Jul 19 21:19:26 localhost kernel:  blk_queue_bypass_start+0x73/0x80
Jul 19 21:19:26 localhost kernel:  blkcg_deactivate_policy+0xff/0x120
Jul 19 21:19:26 localhost kernel:  blk_throtl_exit+0x34/0x50
Jul 19 21:19:26 localhost kernel:  blkcg_exit_queue+0x3a/0x40
Jul 19 21:19:26 localhost kernel:  blk_release_queue+0x2f/0x100
Jul 19 21:19:26 localhost kernel:  kobject_release+0x67/0x170
Jul 19 21:19:26 localhost kernel:  kobject_put+0x2b/0x50
Jul 19 21:19:26 localhost kernel:  blk_exit_rl+0x3a/0x50
Jul 19 21:19:26 localhost kernel:  blkg_free.part.7+0x4f/0xc0
Jul 19 21:19:26 localhost kernel:  __blkg_release_rcu+0x61/0xd0
Jul 19 21:19:26 localhost kernel:  rcu_nocb_kthread+0x15f/0x500
Jul 19 21:19:26 localhost kernel:  kthread+0x125/0x140
Jul 19 21:19:26 localhost kernel:  ? get_state_synchronize_sched+0x20/0x20
Jul 19 21:19:26 localhost kernel:  ? kthread_park+0x90/0x90
Jul 19 21:19:26 localhost kernel:  ret_from_fork+0x25/0x30


Expected results:
no calltrace.

Additional info:

Someone reported the same issue in fedora kernel mailing list before: https://www.spinics.net/linux/fedora/fedora-kernel/msg06777.html
Comment 1 Laura Abbott 2017-07-19 10:22:00 EDT

*** This bug has been marked as a duplicate of bug 1471459 ***

Note You need to log in before you can comment on or make changes to this bug.