Bug 1472851 - Private mirror not included in mirrors.fedoraproject.org F26 metadata
Private mirror not included in mirrors.fedoraproject.org F26 metadata
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mirrormanager (Show other bugs)
26
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 10:11 EDT by George Joseph
Modified: 2017-07-20 11:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 11:22:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
good updates metadata (11.92 KB, application/metalink+xml)
2017-07-19 10:11 EDT, George Joseph
no flags Details
bad releases metadata (12.35 KB, application/metalink+xml)
2017-07-19 10:12 EDT, George Joseph
no flags Details

  None (edit)
Description George Joseph 2017-07-19 10:11:54 EDT
Created attachment 1301129 [details]
good updates metadata

Sorry if this is the wrong place to report issues with mirrors.fedoraproject.org but I can't seem to find any other place to report them. 

Description of problem:

I've had a private mirror of Fedora for almost 9 years and it's been working fine. 
Site: wxy78.net
Host: mirror.wxy78.net (not reachable from public internet but I can make it available if it'll help troubleshoot)

I added releases/26 and updates/26 to my mirror and ran report_mirror, but only the updates metadata shows my local mirror.  I still get my F25 releases and updates fine, just not F26 releases.  

MirrorManager (https://admin.fedoraproject.org/mirrormanager/host/2307/category/7769) does show the releases/26 directory and I've even deleted the host and re-created it.  Still nothing.

The netblocks are obviously working since I'm getting the correct metadata for updates.

Version-Release number of selected component (if applicable):

Started with F26


How reproducible:

Constant

Steps to Reproduce:
1.
2.
3.

Actual results:

releases.xml is missings local mirror mirror.wxy78.net

Expected results:

releases.xml should contain local mirror mirror.wxy78.net


Additional info:
Comment 1 George Joseph 2017-07-19 10:12 EDT
Created attachment 1301130 [details]
bad releases metadata
Comment 2 Adrian Reber 2017-07-19 10:29:54 EDT
The Fedora 26 repository is still pointing to development/26 as soon as we switch to releases/26 your mirror should be listed again. The switch will happen "soon".
Comment 3 George Joseph 2017-07-19 11:47:04 EDT
(In reply to Adrian Reber from comment #2)
> The Fedora 26 repository is still pointing to development/26 as soon as we
> switch to releases/26 your mirror should be listed again. The switch will
> happen "soon".

Damn.  I didn't even notice that in the xml.  I think I got confused because all the mirrors I checked last week had it in releases although checking again today, some other mirrors only have it in development.

Anyway, I did a "btrfs sub snap" and ran report_mirror again so hopefully the metadata will update shortly.
Comment 4 George Joseph 2017-07-20 07:31:49 EDT
Yep, that was it.  Metadata is now showing my local mirror.  Feel free to close this issue.

For future reference, was this the correct product and component to report issues with the mirror manager?
Comment 5 Adrian Reber 2017-07-20 11:22:03 EDT
If you look at the metalink output now it points to the release directory and you should be able to remove the development tree from your mirror.

The correct place to report bugs about Fedora's mirrormanager instance would be:

https://pagure.io/fedora-infrastructure/issues

Bugzilla is for the mirrormanager package.

Note You need to log in before you can comment on or make changes to this bug.