This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1473002 - xsel needs patch to support pasting into java programs
xsel needs patch to support pasting into java programs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xsel (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 16:04 EDT by Raman Gupta
Modified: 2017-08-18 06:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.2.0-19
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-18 06:05:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raman Gupta 2017-07-19 16:04:56 EDT
Description of problem:

xsel, and programs that use it for clipboard like Keepass, cannot copy/paste into Java programs. This seems to be a java bug open since 2005:

http://bugs.java.com/bugdatabase/view_bug.do?bug_id=6322854

xsel has an unreleased patch to avoid this problem: kfish/xsel#6

It would be great if this patch could be added to the xsel rpm.


How reproducible: 100% of the time.


Steps to Reproduce:
1. echo "asdf" | xsel -i -b
2. Attempt to paste into a java program like IntelliJ IDEA or Jitsi or Netbeans

Other references:

https://github.com/jitsi/jitsi/issues/125
https://youtrack.jetbrains.com/issue/IDEA-176209
http://bugs.java.com/bugdatabase/view_bug.do?bug_id=6322854
https://netbeans.org/bugzilla/show_bug.cgi?id=126145
https://aur.archlinux.org/packages/xsel-git/
Comment 1 Tomas Radej 2017-07-26 04:40:36 EDT
Hi, I can't really give xsel enough love due to my time constraints, and I own the package mostly so that it doesn't get removed from the repos. I am more than open to accepting contributions, so if this is high priority for you, I'll accept a patch to the RPM if you make it. Sorry, TR
Comment 2 Mikolaj Izdebski 2017-07-26 06:17:18 EDT
Tomas, I will take care of this.
Comment 3 Fedora Update System 2017-07-26 06:58:13 EDT
xsel-1.2.0-19.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-31d69e1632
Comment 4 Tomas Radej 2017-07-26 07:56:12 EDT
Thanks, Mikolaj.
Comment 5 Fedora Update System 2017-07-26 22:52:59 EDT
xsel-1.2.0-19.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-31d69e1632
Comment 6 Fedora Update System 2017-08-17 20:25:42 EDT
xsel-1.2.0-19.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Mikolaj Izdebski 2017-08-18 06:05:38 EDT
I believe that this bug is fixed in xsel-1.2.0-19,
which is available in updates for Fedora 26, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=924868

Note You need to log in before you can comment on or make changes to this bug.