Bug 147322 - openoffice.org-kde missing from x86_64
Summary: openoffice.org-kde missing from x86_64
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-07 10:37 UTC by Alexandre Oliva
Modified: 2014-03-17 02:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 12:37:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2005-02-07 10:37:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
It is missing from the x86_64 directory in a development tree, and it
was not present in FC3/x86_64 install CDs, so an `everything' install
wouldn't have it, and updates wouldn't bring it in.

Only openoffice.org and openoffice.org-i18n are mentioned in
comps.xml; openoffice.org-libs are brought in as deps of the first. 
-kde is not mentioned in comps.xml (i386 and x86_64).  I suppose it
makes to the i386 tree just because it's built out of the same
.src.rpm as the other openoffice.org packages in i386, but it is not
in x86_64 because it's not x86_64 and there's no explicit reference to
it to force it to be brought in.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Look in development/x86_64/Fedora/RPMS

Actual Results:  openoffice.org-kde is not there

Expected Results:  it should be

Additional info:

Comment 1 Bill Nottingham 2005-02-07 19:49:53 UTC
What is its purpose, and why does it need to be multilib?

Comment 2 Alexandre Oliva 2005-02-07 20:13:25 UTC
It doesn't need to be multilib.  OOo is not built for x86_64, so we
use the i386 binaries.  Except for -kde, that is just missing.

Comment 3 Bill Nottingham 2005-02-07 20:19:57 UTC
'mutilib' == 'the same arch as multilib OOo'. What is its relation to
 OOo, why does it need to be the same bitwidth ( as opposed to
OOo-style-gnome.)

Comment 4 Bill Nottingham 2005-02-07 20:22:47 UTC
Nevermind, added.

Comment 5 Bill Nottingham 2005-02-07 20:23:51 UTC
At least, this will cause it to get pulled into the tree. This could
cause mass chaos on multilib arches, though. Will have to see how it
percolates out in rawhide.

Comment 6 Alexandre Oliva 2005-02-09 02:48:25 UTC
I suspect something went wrong with this fix.  Today's and yesterday's
x86_64 rawhide were missing not only openoffice.org-kde, but also
*all* other i386 packages that used to be there before.

Comment 7 Alexandre Oliva 2005-02-10 12:37:06 UTC
Seems to have been fixed in yesterday's rawhide, thanks!


Note You need to log in before you can comment on or make changes to this bug.