Bug 147326 - wxPython does not build on x86_64
Summary: wxPython does not build on x86_64
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: wxPython (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-07 12:06 UTC by Thorsten Leemhuis
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 19:17:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file patch: remove distutils before build - fixes x86_84 (1.00 KB, patch)
2005-02-08 19:28 UTC, Thorsten Leemhuis
no flags Details | Diff
wxPythonGTK2 spec file patch: remove distutils before build - fixes build on x86_84 (1.03 KB, patch)
2005-02-08 19:30 UTC, Thorsten Leemhuis
no flags Details | Diff

Description Thorsten Leemhuis 2005-02-07 12:06:54 UTC
Description of problem:
wxPython does not build on x86_64; Build Log currently at:
http://fedoraproject.org/extras/3/build-logs/x86_64/wxPython.log

Version-Release number of selected component (if applicable):
wxPython-2.4.2.4-1

Additional info:
The problems seems to be caused by the included distutils that is not
multilib-safe; After a
rm -rf wxPython/distutils
it build fine. Not sure if thise is a correct fix; But newer upstream versions
also don't ship it anymore:
http://starship.python.net/crew/robind/wxPython/daily/20041021/CHANGES.html

The disutils problem is also described in this mail:
http://mail.python.org/pipermail/python-dev/2004-May/044692.html
But after fixing (s/lib/lib64/ in the para refered in the above mail) build
fails a bit later at another point :-(

Panu, what do you think is the best way to fix? You know python way better than
I do.

Comment 1 Thorsten Leemhuis 2005-02-07 12:17:34 UTC
Forgot: Removing wxPython/distutils/ also fixes build of wxPythonGTK2-2.4.2.4-3
on x86_64

Comment 2 Toshio Kuratomi 2005-02-07 19:53:01 UTC
I haven't looked at the wxPython/wxPythonGTK sources yet, but my impression from
[1]_ is that Fedora's python package has a modified distutils to enable multilib
support.  Reading the information on the starship site you mention, it looks
like the included distutils isn't needed on Python >= 2.1.  So my take is going
with the system distutils instead of the included one is the right thing to do.

[1]_ https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=125472

Comment 3 Panu Matilainen 2005-02-07 20:01:22 UTC
I'm not able to check this on x86_64 but based on the comments so far I think
using the system distutils is the "right thing" to do.

Comment 4 Thorsten Leemhuis 2005-02-07 20:12:28 UTC
(In reply to comment #3)
> I'm not able to check this on x86_64 but based on the comments so far I think
> using the system distutils is the "right thing" to do.

just to be sure: Is this achieved by removing the distutils subdir (it seems
so...)? And is that a correct way to fix or is there any better?

And if we do that: only for x86_64 or also for i386?

Comment 5 Panu Matilainen 2005-02-08 08:41:38 UTC
Removing the distutils subdir seems to produce sane results on i386 as well (and
why wouldn't it?) I don't know of any "better" fix for it, if removing it fixes
the issue then I wouldn't worry about it too much :)

Comment 6 Thorsten Leemhuis 2005-02-08 19:28:19 UTC
Created attachment 110814 [details]
spec file patch: remove distutils before build - fixes x86_84

FYI: spec file patch: remove distutils before build - fixes build on x86_84

Comment 7 Thorsten Leemhuis 2005-02-08 19:30:02 UTC
Created attachment 110815 [details]
wxPythonGTK2 spec file patch: remove distutils before build - fixes build on x86_84

Comment 8 Thorsten Leemhuis 2005-02-10 17:49:50 UTC
Panu, are these patches okay for you? Shall I commit to CVS or to you
want to do it yourself?

Comment 9 Panu Matilainen 2005-02-10 18:36:11 UTC
Go ahead and commit - I don't have CVS access...

Comment 10 Thorsten Leemhuis 2005-02-10 19:17:07 UTC
>I don't have CVS access...
Sorry Panu, I thought you had. Commited and build requested. Thanks guys.


Note You need to log in before you can comment on or make changes to this bug.