Bug 147332 - kickpim does not build on x86_64
kickpim does not build on x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kickpim (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-07 08:12 EST by Thorsten Leemhuis
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 11:59:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec patch that fixes building on x86_64 (919 bytes, patch)
2005-02-07 08:12 EST, Thorsten Leemhuis
no flags Details | Diff
specfile patch (1.64 KB, patch)
2005-02-07 08:56 EST, Rex Dieter
no flags Details | Diff

  None (edit)
Description Thorsten Leemhuis 2005-02-07 08:12:54 EST
Description of problem:
kickpim does not build on x86_64; See:
http://fedoraproject.org/extras/3/build-logs/x86_64/kickpim.log

Version-Release number of selected component (if applicable):
0.5.3-4

Additional info:
Fixed by the attached patch. Rex any comments on it? Would it be okay for you if
we would apply it to CVS?
Comment 1 Thorsten Leemhuis 2005-02-07 08:12:54 EST
Created attachment 110717 [details]
spec patch that fixes building on x86_64
Comment 2 Rex Dieter 2005-02-07 08:44:14 EST
Why add -DPIC too, instead of just -fPIC as the build log suggested?

What is meant by the changelog comment: "using the configure option does not fix
it"?  That setting CXXFLAGS before configure didn't work?  Like:

%ifarch x86_64
export CXXFLAGS="-fPIC $RPM_OPT_FLAGS"
%endif
%configure ...
Comment 3 Rex Dieter 2005-02-07 08:56:50 EST
Created attachment 110723 [details]
specfile patch

- fix x86_64 build
- tighten kdelibs dep
- cleanup %%configure
Comment 4 Rex Dieter 2005-02-07 09:04:53 EST
This way, %%configure uses the same compiler flags as the 'make' step does. 
Also snuck in a few other minor improvements.

If it turns out -DPIC really is needed too, feel free to add that too.
Comment 5 Thorsten Leemhuis 2005-02-07 09:10:35 EST
(In reply to comment #2)
> Why add -DPIC too, instead of just -fPIC as the build log suggested?

Someone mentioned that this should be done this way, but I can't remember where.
 And I saw mschendt using it also:
https://www.redhat.com/archives/fedora-extras-commits/2005-February/msg00095.html
But I don't know the details :(

>What is meant by the changelog comment: "using the configure option does not
>fix it"?  That setting CXXFLAGS before configure didn't work?  
Sorry, trimmed it to much; there is a configure option --with-pic /
--without-pic. But it does not work.

(In reply to comment #3)
> Created an attachment (id=110723) [edit]
> specfile patch

Thanks Rex. Yes, this also fixes build on x86-64.
Comment 6 Michael Schwendt 2005-02-07 09:23:28 EST
No need to worry. -DPIC is probably redundant, bad habit, but still used by
libtool and might be that some software ifdefs PIC. No time to investigate. If
memory serves correctly, -fPIC internally sets -D__PIC__ already.
Comment 7 Thorsten Leemhuis 2005-02-10 11:59:09 EST
Commited attachment (id=110723) to CVS and requested build. Thanks Rex.

Note You need to log in before you can comment on or make changes to this bug.