Bug 1473499 - Could not reach workflow server at https://hardware.redhat.com/xmlrpc.cgi
Could not reach workflow server at https://hardware.redhat.com/xmlrpc.cgi
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog Entry (Show other bugs)
FEAT
All All
unspecified Severity medium
: ---
: ---
Assigned To: Rob Landry
Red Hat Hardware Certification
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 22:43 EDT by Freeman Zhang
Modified: 2017-09-06 02:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-06 02:25:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Freeman Zhang 2017-07-20 22:43:02 EDT
Description of problem:

I'm not sure if this is a server issue or caused by the Internet network in China.

I'm an engineer in an OEM company and running RHEL certification test, located in Shanghai China. I have built the test environment following Test Suite User Guide and have already run some test cases in the SUT. Just in last week I can refresh the program list, create new certification, receive test plan from Red Hat team and run some test cases.

But recently whenever I open the web browser in SUT, I get an error message that indicates the TC and SUT cannot connect to https://hardware.redhat.com/xmlrpc.cgi.

Could you please check if this is a server issue?

Version-Release number of selected component (if applicable):

Red Hat Certification packages on https://access.redhat.com/downloads/content/282/ver=/rhel---7/7/x86_64/packages

How reproducible:


Steps to Reproduce:
1. Follow the Test Suite User Guide and build the test environment 
2. In SUT, open a browser and connect to TC
3. Check the page loaded

Actual results:

An error dialog shows: Unable to connect! Our catalog is not presently reachable.

And in the details: Network error, unable to connect to server. While trying to reach Error: could not reach workflow server at https://hardware.redhat.com/xmlrpc.cgi: the following error was encountered: Error: [Errno -2] Name or service not known

And I cannot login, refresh the program list, and continue the test. But the SUT and TC is connected to Internet. I can open other web site, for example, file this new bug on bugzilla.redhat.com

Expected results:

There should be no error information in the web page.

Additional info:
Comment 1 Freeman Zhang 2017-09-06 02:25:09 EDT
No longer a blocking issue to me.

Note You need to log in before you can comment on or make changes to this bug.