This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1473660 - installer is also trying to install other pure new node when running master scale up playbook.
installer is also trying to install other pure new node when running master s...
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 07:58 EDT by Johnny Liu
Modified: 2017-08-14 11:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-14 11:51:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
inventory host file and log (171.14 KB, application/x-gzip)
2017-07-21 08:11 EDT, Johnny Liu
no flags Details

  None (edit)
Description Johnny Liu 2017-07-21 07:58:44 EDT
Description of problem:
installer is also trying to install other pure new node when running master scale up playbook. 

Version-Release number of the following components:
openshift-ansible-3.6.153-1.git.0.5a6bf7d.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. setup up a master HA env.
2. launch 2 new hosts, one is for new master, another is for new node.
3. on the two instance, subscribe channel, and install excluder.
4. add new_masters and new_nodes into inventory host file
5. run "playbooks/byo/openshift-master/scaleup.yml" to do master scale up

Actual results:
playbook failed.
TASK [openshift_common : Install the base package for versioning] **************
Friday 21 July 2017  11:03:44 +0000 (0:00:01.575)       0:07:29.630 *********** 

ok: [qe-jialiu-master-new-1.0721-04f.qe.rhcloud.com] => {
    "changed": false, 
    "rc": 0, 
    "results": [
        "atomic-openshift-3.6.153-1.git.0.4894417.el7.x86_64 providing atomic-openshift-3.6.153 is already installed"
    ]
}
fatal: [qe-jialiu-node-new-1.0721-04f.qe.rhcloud.com]: FAILED! => {
    "changed": false, 
    "failed": true, 
    "rc": 126, 
    "results": [
        "No package matching 'atomic-openshift-3.6.153' found available, installed or updated"
    ]
}

MSG:

No package matching 'atomic-openshift-3.6.153' found available, installed or updated

That is because master scaleup also involve other pure new_nodes, while openshift_excluder does not do unexclude operation.

openshift_excluder role is doing right things, only do unexlude operation on master. while installer is also trying to install other pure new nodes.

Expected results:
when running master scaleup, installer should only install master and node service this new_masters, should NOT install other pure new node.
pure new node install work should be left to playbooks/byo/openshift-master/scaleup.yml.


Additional info:
Comment 1 Johnny Liu 2017-07-21 08:11 EDT
Created attachment 1302331 [details]
inventory host file and log
Comment 2 Scott Dodson 2017-08-14 11:51:48 EDT
I'm going to mark this as CLOSED WONTFIX. When performing scaleup operations it's expected that only new_nodes or new_masters exist in the inventory and if that were the case this problem wouldn't happen.

Note You need to log in before you can comment on or make changes to this bug.