Bug 1473677 - 'mock --init -r fedora-rawhide-x86_64' does not work on RHEL-6 any more
'mock --init -r fedora-rawhide-x86_64' does not work on RHEL-6 any more
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 08:19 EDT by Kamil Dudka
Modified: 2017-07-22 04:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-21 08:45:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Dudka 2017-07-21 08:19:42 EDT
Description of problem:
mock can no longer be used to build Fedora rawhide packages on a RHEL-6 box
because glibc started to require a newer running kernel.  The required kernel
version is, however, not available for RHEL-6.


Version-Release number of selected component (if applicable):
glibc-2.25.90-27.fc27


Steps to Reproduce:
# yum install mock
# mock --yum --init -r fedora-rawhide-x86_64


Actual results:
[...]
  Installing : glibc-common-2.25.90-25.fc27.x86_64                     19/157 
Error in PREIN scriptlet in rpm package glibc-2.25.90-25.fc27.x86_64
error: lua script failed: FATAL: kernel too old
error:   install: %pre scriptlet failed (2), skipping glibc-2.25.90-25.fc27
  Installing : ncurses-libs-6.0-10.20170520.fc27.x86_64                21/157 
warning: %post(ncurses-libs-6.0-10.20170520.fc27.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package ncurses-libs-6.0-10.20170520.fc27.x86_64
  Installing : bash-4.4.12-6.fc27.x86_64                               22/157 
  Installing : libsepol-2.6-1.fc26.x86_64                              23/157 
warning: %post(libsepol-2.6-1.fc26.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package libsepol-2.6-1.fc26.x86_64
  Installing : pcre-8.41-1.fc27.x86_64                                 24/157
[...]


Expected results:
Successfully initialized mock profile.


Additional info:
This is a regression introduced by the following downstream commit:
https://src.fedoraproject.org/cgit/rpms/glibc.git/commit/?id=fda3e070
Comment 1 Carlos O'Donell 2017-07-21 08:45:31 EDT
(In reply to Kamil Dudka from comment #0)
> Description of problem:
> mock can no longer be used to build Fedora rawhide packages on a RHEL-6 box
> because glibc started to require a newer running kernel.  The required kernel
> version is, however, not available for RHEL-6.

This is the expected behaviour. You need a Linux 3.2 or newer kernel to run glibc 2.25.90 (2.26 development series).

You can no longer build Fedora Rawhide packages on RHEL 6. Workarounds include booting a VM with a newer Linux kernel to build glibc. Alternatively you can upgrade to RHEL 7.

From the glibc NEWS:

Version 2.26

...

* The minimum Linux kernel version that this version of the GNU C Library
  can be used with on i[4567]86 and x86_64 is 3.2.  A Linux 3.2 or later
  kernel was already required on all other architectures.

Therefore this is CLOSED / NOTABUG.

Eventually upstream will remove the "FATAL: kernel to old" error message and allow individual syscalls to fail.

Note You need to log in before you can comment on or make changes to this bug.