Bug 1473699 - symlinks noted as config files persists update
symlinks noted as config files persists update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: jiri vanek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 08:50 EDT by jiri vanek
Modified: 2017-11-16 05:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-16 05:07:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jiri vanek 2017-07-21 08:50:54 EDT
Although new c-j-c really helped  with multiple installs and config files, links avoideded. After udate to u141, I had:


lrwxrwxrwx 1 root root   26 Jul 21 14:44 java -> /etc/alternatives/java_sdk
lrwxrwxrwx 1 root root   32 Dec  1  2016 java-1.6.0 -> /etc/alternatives/java_sdk_1.6.0
drwxr-xr-x 7 root root 4096 Nov  9  2016 java-1.6.0-openjdk-legacy-1.6.0.40.x86_64
lrwxrwxrwx 1 root root   41 Nov  9  2016 java-1.6.0-openjdk.x86_64 -> java-1.6.0-openjdk-legacy-1.6.0.40.x86_64
lrwxrwxrwx 1 root root   32 May 24 10:15 java-1.7.0 -> /etc/alternatives/java_sdk_1.7.0
lrwxrwxrwx 1 root root   40 May 24 10:15 java-1.7.0-openjdk -> /etc/alternatives/java_sdk_1.7.0_openjdk
drwxr-xr-x 8 root root 4096 Jul  7 08:05 java-1.7.0-openjdk-legacy-1.7.0.141-2.6.10.1.fc24.x86_64
lrwxrwxrwx 1 root root   32 Jul 21 14:44 java-1.8.0 -> /etc/alternatives/java_sdk_1.8.0
lrwxrwxrwx 1 root root   40 Jul 21 14:44 java-1.8.0-openjdk -> /etc/alternatives/java_sdk_1.8.0_openjdk
drwxr-xr-x 3 root root 4096 Apr 27 13:09 java-1.8.0-openjdk-1.8.0.121-10.b14.fc24.x86_64
drwxr-xr-x 3 root root 4096 Jun 15 17:10 java-1.8.0-openjdk-1.8.0.131-1.b12.fc24.x86_64
drwxr-xr-x 7 root root 4096 Jul 21 14:43 java-1.8.0-openjdk-1.8.0.141-1.b16.fc24.x86_64
lrwxrwxrwx 1 root root   28 Jul 18 13:24 java-9 -> /etc/alternatives/java_sdk_9
lrwxrwxrwx 1 root root   36 Jul 18 13:24 java-9-openjdk -> /etc/alternatives/java_sdk_9_openjdk
drwxr-xr-x 9 root root 4096 Jul 19 14:45 java-9-openjdk-9.0.0.178-1.fc24.x86_64
lrwxrwxrwx 1 root root   34 Jul 21 14:44 java-openjdk -> /etc/alternatives/java_sdk_openjdk
lrwxrwxrwx 1 root root   21 Jul 21 14:44 jre -> /etc/alternatives/jre
lrwxrwxrwx 1 root root   27 Dec  1  2016 jre-1.6.0 -> /etc/alternatives/jre_1.6.0
lrwxrwxrwx 1 root root   45 Nov  9  2016 jre-1.6.0-openjdk.x86_64 -> java-1.6.0-openjdk-legacy-1.6.0.40.x86_64/jre
lrwxrwxrwx 1 root root   35 May 24 10:15 jre-1.7.0-openjdk -> /etc/alternatives/jre_1.7.0_openjdk
lrwxrwxrwx 1 root root   60 May 12 17:47 jre-1.7.0-openjdk-1.7.0.141-2.6.10.1.fc24.x86_64 -> java-1.7.0-openjdk-legacy-1.7.0.141-2.6.10.1.fc24.x86_64/jre
lrwxrwxrwx 1 root root   27 Jul 21 14:44 jre-1.8.0 -> /etc/alternatives/jre_1.8.0
lrwxrwxrwx 1 root root   35 Jul 21 14:44 jre-1.8.0-openjdk -> /etc/alternatives/jre_1.8.0_openjdk
lrwxrwxrwx 1 root root   50 Jul 21 14:33 jre-1.8.0-openjdk-1.8.0.141-1.b16.fc24.x86_64 -> java-1.8.0-openjdk-1.8.0.141-1.b16.fc24.x86_64/jre
lrwxrwxrwx 1 root root   23 Jul 18 13:24 jre-9 -> /etc/alternatives/jre_9
lrwxrwxrwx 1 root root   31 Jul 18 13:24 jre-9-openjdk -> /etc/alternatives/jre_9_openjdk
lrwxrwxrwx 1 root root   38 Jul 18 11:40 jre-9-openjdk-9.0.0.178-1.fc24.x86_64 -> java-9-openjdk-9.0.0.178-1.fc24.x86_64
lrwxrwxrwx 1 root root   29 Jul 21 14:44 jre-openjdk -> /etc/alternatives/jre_openjdk
 jvanek  jvanek  14:44:31  usr  lib  jvm    $  tree  java-1.8.0-openjdk-1.8.0.121-10.b14.fc24.x86_64
java-1.8.0-openjdk-1.8.0.121-10.b14.fc24.x86_64
└── jre
    └── lib
        └── security
            └── cacerts -> ../../../../../../../etc/pki/java/cacerts

3 directories, 1 file
 jvanek  jvanek  14:44:35  usr  lib  jvm    $  tree  java-1.8.0-openjdk-1.8.0.131-10.b14.fc24.x86_64
java-1.8.0-openjdk-1.8.0.131-10.b14.fc24.x86_64 [error opening dir]

0 directories, 0 files
 jvanek  jvanek  14:44:38  usr  lib  jvm    $  tree  java-1.8.0-openjdk-1.8.0.131-1.b12.fc24.x86_64/
java-1.8.0-openjdk-1.8.0.131-1.b12.fc24.x86_64/
└── jre
    └── lib
        └── security
            └── cacerts -> ../../../../../../../etc/pki/java/cacerts


So obviously links are skipped by that tool. There is already something link-related happening in usptream of c-j-c due to jdk9.
Comment 1 Jan Kurik 2017-08-15 05:05:14 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 2 jiri vanek 2017-11-16 05:07:52 EST
Should be fixed via c-j-c 3, which handles symlinks

Note You need to log in before you can comment on or make changes to this bug.