Bug 1473748 - Qbittorrent 3.3.13 web API does not work with custom clients.
Qbittorrent 3.3.13 web API does not work with custom clients.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qbittorrent (Show other bugs)
26
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabio Alessandro Locati
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 10:31 EDT by igo9586
Modified: 2018-03-06 12:29 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.3.14 qbittorrent-4.0.4-1.fc27 qbittorrent-4.0.4-1.fc26
Doc Type: Known Issue
Doc Text:
Cause: Incorrect change in 3.3.13 makes the client web API to reject any request if headers 'refer' and 'Host' don't match Consequence: No custom web interface works. Workaround (if any): Update to 3.3.14 Result: Allegedly fixed in 3.3.14
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-27 12:24:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description igo9586 2017-07-21 10:31:21 EDT
The issue is that since 3.3.13 it only accepts the requests there headers 'refer' and 'Host' are same. Allegedly it was fixed in 3.3.14

Information from those threads:
https://github.com/qbittorrent/qBittorrent/issues/6882
https://github.com/qbittorrent/qBittorrent/pull/6887
Comment 1 Fedora Update System 2018-02-22 06:49:49 EST
qbittorrent-4.0.4-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5b06928b04
Comment 2 Fedora Update System 2018-02-22 06:50:03 EST
qbittorrent-4.0.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf943c3e99
Comment 3 Fedora Update System 2018-02-23 11:26:32 EST
qbittorrent-4.0.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf943c3e99
Comment 4 Fedora Update System 2018-02-23 11:56:54 EST
qbittorrent-4.0.4-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5b06928b04
Comment 5 Fedora Update System 2018-02-27 12:24:17 EST
qbittorrent-4.0.4-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2018-03-06 12:29:04 EST
qbittorrent-4.0.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.