Bug 1473845 - acl build fails with "Unescaped left brace in regex"
acl build fails with "Unescaped left brace in regex"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: acl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 16:34 EDT by Troy Dawson
Modified: 2017-07-24 09:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: acl-2.2.52-16.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 09:48:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix acls tests (2.23 KB, patch)
2017-07-21 16:51 EDT, Troy Dawson
no flags Details | Diff

  None (edit)
Description Troy Dawson 2017-07-21 16:34:19 EDT
Description of problem:
When building acl in rawhide, it fails on the tests with the error
"Unescaped left brace in regex is illegal here in regex"
This is due to the newer version of Perl changing that error from a warning to an error.

Version-Release number of selected component (if applicable):
acl-2.2.52-15.fc27

How reproducible:
100%

Steps to Reproduce:
1. koji build --scratch rawhide acl-2.2.52-15.fc27.src.rpm
2.
3.

Actual results:
...
gmake[1]: Entering directory '/builddir/build/BUILD/acl-2.2.52/test'
*** malformed-restore.test ***
Unescaped left brace in regex is illegal here in regex; marked by <-- HERE in m/%{ <-- HERE (\w+)}/ at run line 73.
gmake[1]: *** [Makefile:39: malformed-restore.test] Error 255
gmake[1]: Leaving directory '/builddir/build/BUILD/acl-2.2.52/test'
make: *** [Makefile:115: tests] Error 2
+ exit 2
...

Expected results:
rpm build to succeed

Additional info:
Perl changed from perl-5.24.1 in fedora 26 to perl-5.26.0 in rawhide (f27)
Comment 1 Troy Dawson 2017-07-21 16:35:29 EDT
Failed Build:
https://koji.fedoraproject.org/koji/taskinfo?taskID=20652452
Comment 2 Troy Dawson 2017-07-21 16:51 EDT
Created attachment 1302557 [details]
Patch to fix acls tests

I have attached a patch to fix the tests for the new Perl.
Here is a successful rawhide scratch build with the patch applied.
https://koji.fedoraproject.org/koji/taskinfo?taskID=20652773
Comment 3 Troy Dawson 2017-07-21 16:57:07 EDT
I understand that not everyone has time to work on failed builds.  But this failed build is blocking some automated building for the bootstrap and module team.
If you are unable to update the rpm within two weeks, we will have a proven packager apply the patch in this bug.
If you know you will be too busy and wouldn't mind us applying it sooner, just let us know.
Comment 4 Kamil Dudka 2017-07-24 08:33:47 EDT
upstream commit:
http://git.savannah.gnu.org/cgit/acl.git/commit?id=v2.2.52-33-gf2feb94
Comment 5 Kamil Dudka 2017-07-24 09:48:13 EDT
downstream commit:
https://src.fedoraproject.org/cgit/rpms/acl.git/commit/?id=3147a227

Note You need to log in before you can comment on or make changes to this bug.