Bug 1473853 - attr build fails with "Unescaped left brace in regex"
attr build fails with "Unescaped left brace in regex"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: attr (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 17:11 EDT by Troy Dawson
Modified: 2017-07-24 09:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: attr-2.4.47-19.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 09:32:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix attr tests (1.17 KB, patch)
2017-07-21 17:19 EDT, Troy Dawson
no flags Details | Diff

  None (edit)
Description Troy Dawson 2017-07-21 17:11:59 EDT
Description of problem:
When building attr in rawhide, it fails on the tests with the error
"Unescaped left brace in regex is illegal here in regex"
This is due to the newer version of Perl changing that error from a warning to an error.

Version-Release number of selected component (if applicable):
attr-2.4.47-18.fc26

How reproducible:
100%

Steps to Reproduce:
1.koji build --scratch rawhide attr-2.4.47-18.fc26.src.rpm 
2.
3.

Actual results:
...
gmake[1]: Entering directory '/builddir/build/BUILD/attr-2.4.47/test'
*** attr.test ***
Unescaped left brace in regex is illegal here in regex; marked by <-- HERE in m/%{ <-- HERE (\w+)}/ at run line 87.
gmake[1]: Leaving directory '/builddir/build/BUILD/attr-2.4.47/test'
gmake[1]: *** [Makefile:40: attr.test] Error 255
make: *** [Makefile:120: tests] Error 2
+ exit 2
...

Expected results:
rpm to build

Additional info:
Perl changed from perl-5.24.1 in fedora 26 to perl-5.26.0 in rawhide (f27)
Here is a failed scratch build
https://koji.fedoraproject.org/koji/taskinfo?taskID=20652575
Comment 1 Troy Dawson 2017-07-21 17:19 EDT
Created attachment 1302558 [details]
Patch to fix attr tests

Patch to fix acls tests

I have attached a patch to fix the tests for the new Perl.
Here is a successful rawhide scratch build with the patch applied.
https://koji.fedoraproject.org/koji/taskinfo?taskID=20653521
Comment 2 Troy Dawson 2017-07-21 17:20:12 EDT
I understand that not everyone has time to work on failed builds.  But this failed build is blocking some automated building for the bootstrap and module team.
If you are unable to update the rpm within two weeks, we will have a proven packager apply the patch in this bug.
If you know you will be too busy and wouldn't mind us applying it sooner, just let us know.
Comment 3 Kamil Dudka 2017-07-24 09:04:23 EDT
Thanks for the patch!  I have submitted it upstream on your behalf:

http://lists.nongnu.org/archive/html/acl-devel/2017-07/msg00001.html
Comment 4 Kamil Dudka 2017-07-24 09:32:19 EDT
downstream commit:

https://src.fedoraproject.org/cgit/rpms/attr.git/commit/?id=ad4426d2

Note You need to log in before you can comment on or make changes to this bug.