Bug 1473877 - sagemath-8.2 is available
sagemath-8.2 is available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sagemath (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paulo Andrade
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 20:24 EDT by Upstream Release Monitoring
Modified: 2018-06-06 22:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-06 22:48:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2017-07-21 20:24:38 EDT
Latest upstream release: 8.0
Current version/release in rawhide: 7.6-3.fc27
URL: http://www.sagemath.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4756/
Comment 1 Upstream Release Monitoring 2017-07-21 20:25:06 EDT
One or more of the specfile's Sources is not a valid URL so we cannot automatically build the new version for you. Please use a URL in your Source declarations if possible.
Comment 2 Upstream Release Monitoring 2017-12-07 19:27:46 EST
Latest upstream release: 8.1
Current version/release in rawhide: 8.0-2.fc28
URL: http://www.sagemath.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4756/
Comment 3 Upstream Release Monitoring 2017-12-07 19:29:15 EST
One or more of the specfile's Sources is not a valid URL so we cannot automatically build the new version for you. Please use a URL in your Source declarations if possible.
Comment 4 Upstream Release Monitoring 2018-05-05 20:29:08 EDT
Latest upstream release: 8.2
Current version/release in rawhide: 8.0-2.fc28
URL: http://www.sagemath.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/4756/
Comment 5 artal 2018-05-09 02:57:42 EDT
In order to make work sagemath-8.1 in F28 (compiled in F27 from sources, not the rpm), I needed to recover libgfortran.so.4. I tried to compile sagemath-8.2 in F28; it seems that it is not possible with gcc-8, so I tried with sagemath-gcc but it could not finish to compile python3 due to a problem with the module crypt.
Comment 6 Jerry James 2018-06-06 22:47:47 EDT
(In reply to artal from comment #5)
> In order to make work sagemath-8.1 in F28 (compiled in F27 from sources, not
> the rpm), I needed to recover libgfortran.so.4. I tried to compile
> sagemath-8.2 in F28; it seems that it is not possible with gcc-8, so I tried
> with sagemath-gcc but it could not finish to compile python3 due to a
> problem with the module crypt.

I'm not entirely clear on what you were trying to do, but I just built 8.2 in Rawhide.  Perhaps you could take a look and see if it helps you.
Comment 7 Jerry James 2018-06-06 22:48:05 EDT
Version 8.2 has been built in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.