This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 147395 - OpenOffice crashes with Evolution addressbook
OpenOffice crashes with Evolution addressbook
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-07 16:01 EST by Victor M. Elias
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.9.117-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-18 05:24:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 52023 None None None Never

  None (edit)
Description Victor M. Elias 2005-02-07 16:01:24 EST
Description of problem:
After selecting the datasource to Evolution addressbook, in the 'Data
Sources' left pane, I can see the new addressbook (listed under the
'Tables' sbumenu) but oowriter freezes and crashes as soon as I click
on that addressbook database to use it.


Version-Release number of selected component (if applicable):
GNOME2.8.0
OpenOffice.org1.1.3 
Evolution2.0.2

How reproducible:
every time

Steps to Reproduce:
1. In oowriter, select 'Tools' > 'Data Sources...' to open the dialog box.
2.Under the 'General' tab, select 'Address book' from the drop-down
'Database type' menu.
3. Click 'OK' and bring up 'Data Sources' by clicking the icon on the
oowriter side toolbar.
4. In the left data source area, expand the data source tree until you
see the addressbook listed under 'Tables.'
5. Click on it, and the system crashes.
  
Actual results:
Application crashes.

Expected results:
The data from the address book should have appeared in the main data
source area.

Additional info:
updated through yum
Comment 1 Victor M. Elias 2005-02-07 16:02:47 EST
Bug Buddy info:
Binary file: soffice.bin    Process ID: 28173
Debugging Information:
Backtrace was generated from '/usr/lib/ooo-1.1/program/soffice.bin'

(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...[Thread debugging using
libthread_db enabled]
[New Thread -1208146240 (LWP 28173)]
[New Thread -1309373520 (LWP 28194)]
[Thread debugging using libthread_db enabled]
[New Thread -1208146240 (LWP 28173)]
[New Thread -1309373520 (LWP 28194)]
[Thread debugging using libthread_db enabled]
[New Thread -1208146240 (LWP 28173)]
[New Thread -1309373520 (LWP 28194)]
[New Thread 44858288 (LWP 28191)]
[New Thread 29424560 (LWP 28190)]
(no debugging symbols found)...0x003df7a2 in _dl_sysinfo_int80 () from
/lib/ld-linux.so.2
#0  0x003df7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0048568b in __waitpid_nocancel () from /lib/tls/libc.so.6
#2  0x004303b5 in do_system () from /lib/tls/libc.so.6
#3  0x00430763 in system () from /lib/tls/libc.so.6
#4  0x006397cd in system () from /lib/tls/libpthread.so.0
#5  0x061aafad in osl_releaseVolumeDeviceHandle ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#6  0x061ab243 in osl_releaseVolumeDeviceHandle ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#7  <signal handler called>
#8  0x061b8804 in rtl_uString_release ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#9  0x04e6ca08 in
connectivity::evoab::OEvoabDatabaseMetaData::getColumnRows
    () from /usr/lib/ooo-1.1/program/libevoab2.so
#10 0x04e6e974 in
connectivity::evoab::OEvoabDatabaseMetaData::getColumns ()
   from /usr/lib/ooo-1.1/program/libevoab2.so
#11 0x03dff831 in connectivity::OTableHelper::refreshColumns ()
   from /usr/lib/ooo-1.1/program/libdbtools2.so
#12 0x04d27fbb in ?? () from /usr/lib/ooo-1.1/program/libdba645li.so
#13 0x04d22863 in ?? () from /usr/lib/ooo-1.1/program/libdba645li.so
#14 0x04d2e8cf in ?? () from /usr/lib/ooo-1.1/program/libdba645li.so
#15 0x03dc53f0 in connectivity::sdbcx::OCollection::getObject ()
   from /usr/lib/ooo-1.1/program/libdbtools2.so
#16 0x03dc30a2 in connectivity::sdbcx::OCollection::getByName ()
   from /usr/lib/ooo-1.1/program/libdbtools2.so
#17 0xafce7a63 in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libdbu645li.so
#18 0xafce6e3c in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libdbu645li.so
#19 0xafd0299d in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libdbu645li.so
#20 0xafd0293e in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libdbu645li.so
#21 0x05ca0625 in Timer::Timeout ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#22 0x05ca0319 in ImplTimerCallbackProc ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#23 0x0863ac8c in SalData::Timeout ()
   from /usr/lib/ooo-1.1/program/libvclplug_gen645li.so
#24 0x00c44bce in GtkXLib::timeoutFn ()
   from /usr/lib/ooo-1.1/program/libvclplug_gtk645li.so
#25 0x007a1368 in g_main_context_wakeup () from
/usr/lib/libglib-2.0.so.0
#26 0x0079e7bb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#27 0x007a0242 in g_main_context_acquire () from
/usr/lib/libglib-2.0.so.0
#28 0x007a0728 in g_main_context_iteration () from
/usr/lib/libglib-2.0.so.0
#29 0x00c44ebc in GtkXLib::Yield ()
   from /usr/lib/ooo-1.1/program/libvclplug_gtk645li.so
#30 0x086455db in X11SalInstance::Yield ()
   from /usr/lib/ooo-1.1/program/libvclplug_gen645li.so
#31 0x05c9a2a6 in Application::Yield ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#32 0x05c9a1bd in Application::Execute ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#33 0x08068f69 in desktop::Desktop::Main ()
#34 0x05c9f726 in SVMain () from
/usr/lib/ooo-1.1/program/libvcl645li.so
#35 0x05e6003d in main () from /usr/lib/ooo-1.1/program/libvcl645li.so
#36 0x00410e33 in __libc_start_main () from /lib/tls/libc.so.6
#37 0x08063a41 in _start ()

Thread 4 (Thread 29424560 (LWP 28190)):
#0  0x003df7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x00638718 in accept () from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x061abbaf in osl_acceptPipe () from
/usr/lib/ooo-1.1/program/libsal.so.3
No symbol table info available.
#3  0x00754abf in vos::OPipe::accept ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
No symbol table info available.
#4  0x080725b3 in desktop::OfficeIPCThread::run ()
No symbol table info available.
#5  0x0074df62 in vos::_cpp_OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
No symbol table info available.
#6  0x0074df49 in _OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
No symbol table info available.
#7  0x061a0580 in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
No symbol table info available.
#8  0x006333ae in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#9  0x004c2b6e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 3 (Thread 44858288 (LWP 28191)):
#0  0x003df7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x00635dbc in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x0619cede in osl_waitCondition ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
No symbol table info available.
#3  0x00746ec9 in vos::OCondition::wait ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
No symbol table info available.
#4  0x00751a88 in vos::OTimerManager::run ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
No symbol table info available.
#5  0x0074df62 in vos::_cpp_OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
No symbol table info available.
#6  0x0074df49 in _OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
No symbol table info available.
#7  0x061a0580 in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
No symbol table info available.
#8  0x006333ae in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#9  0x004c2b6e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 2 (Thread -1309373520 (LWP 28194)):
#0  0x003df7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x004b8f74 in poll () from /lib/tls/libc.so.6
No symbol table info available.
#2  0x02e914e3 in ?? () from
/usr/lib/ooo-1.1/program/libdtransX11645li.so
No symbol table info available.
#3  0x02e91616 in ?? () from
/usr/lib/ooo-1.1/program/libdtransX11645li.so
No symbol table info available.
#4  0x061a0580 in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
No symbol table info available.
#5  0x006333ae in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#6  0x004c2b6e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 1 (Thread -1208146240 (LWP 28173)):
#0  0x003df7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0048568b in __waitpid_nocancel () from /lib/tls/libc.so.6
No symbol table info available.
#2  0x004303b5 in do_system () from /lib/tls/libc.so.6
No symbol table info available.
#3  0x00430763 in system () from /lib/tls/libc.so.6
No symbol table info available.
#4  0x006397cd in system () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0x061aafad in osl_releaseVolumeDeviceHandle ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
No symbol table info available.
#6  0x061ab243 in osl_releaseVolumeDeviceHandle ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
No symbol table info available.
#7  <signal handler called>
No symbol table info available.
#8  0x061b8804 in rtl_uString_release ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
No symbol table info available.
#9  0x04e6ca08 in
connectivity::evoab::OEvoabDatabaseMetaData::getColumnRows
    () from /usr/lib/ooo-1.1/program/libevoab2.so
No symbol table info available.
#10 0x04e6e974 in
connectivity::evoab::OEvoabDatabaseMetaData::getColumns ()
   from /usr/lib/ooo-1.1/program/libevoab2.so
No symbol table info available.
#11 0x03dff831 in connectivity::OTableHelper::refreshColumns ()
   from /usr/lib/ooo-1.1/program/libdbtools2.so
No symbol table info available.
#12 0x04d27fbb in ?? () from /usr/lib/ooo-1.1/program/libdba645li.so
No symbol table info available.
#13 0x04d22863 in ?? () from /usr/lib/ooo-1.1/program/libdba645li.so
No symbol table info available.
#14 0x04d2e8cf in ?? () from /usr/lib/ooo-1.1/program/libdba645li.so
No symbol table info available.
#15 0x03dc53f0 in connectivity::sdbcx::OCollection::getObject ()
   from /usr/lib/ooo-1.1/program/libdbtools2.so
No symbol table info available.
#16 0x03dc30a2 in connectivity::sdbcx::OCollection::getByName ()
   from /usr/lib/ooo-1.1/program/libdbtools2.so
No symbol table info available.
#17 0xafce7a63 in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libdbu645li.so
No symbol table info available.
#18 0xafce6e3c in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libdbu645li.so
No symbol table info available.
#19 0xafd0299d in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libdbu645li.so
No symbol table info available.
#20 0xafd0293e in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libdbu645li.so
No symbol table info available.
#21 0x05ca0625 in Timer::Timeout ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
No symbol table info available.
#22 0x05ca0319 in ImplTimerCallbackProc ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
No symbol table info available.
#23 0x0863ac8c in SalData::Timeout ()
   from /usr/lib/ooo-1.1/program/libvclplug_gen645li.so
No symbol table info available.
#24 0x00c44bce in GtkXLib::timeoutFn ()
   from /usr/lib/ooo-1.1/program/libvclplug_gtk645li.so
No symbol table info available.
#25 0x007a1368 in g_main_context_wakeup () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#26 0x0079e7bb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#27 0x007a0242 in g_main_context_acquire () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#28 0x007a0728 in g_main_context_iteration () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#29 0x00c44ebc in GtkXLib::Yield ()
   from /usr/lib/ooo-1.1/program/libvclplug_gtk645li.so
No symbol table info available.
#30 0x086455db in X11SalInstance::Yield ()
   from /usr/lib/ooo-1.1/program/libvclplug_gen645li.so
No symbol table info available.
#31 0x05c9a2a6 in Application::Yield ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
No symbol table info available.
#32 0x05c9a1bd in Application::Execute ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
No symbol table info available.
#33 0x08068f69 in desktop::Desktop::Main ()
No symbol table info available.
#34 0x05c9f726 in SVMain () from
/usr/lib/ooo-1.1/program/libvcl645li.so
No symbol table info available.
#35 0x05e6003d in main () from /usr/lib/ooo-1.1/program/libvcl645li.so
No symbol table info available.
#36 0x00410e33 in __libc_start_main () from /lib/tls/libc.so.6
No symbol table info available.
#37 0x08063a41 in _start ()
No symbol table info available.
Comment 2 Johan Rosman 2005-02-28 04:23:02 EST
I have exactly the same problem after upgrading to version 1.1.3
(version 1.1.2 works ok)
Comment 3 Caolan McNamara 2005-05-04 13:25:33 EDT
Is this still the case in 1.1.3-11.5.0.fc3 ?
Comment 4 Victor M. Elias 2005-05-04 14:06:33 EDT
Yes, it still behaves the same with the updates.
Comment 5 Caolan McNamara 2005-07-15 07:56:22 EDT
looks like it's _GNU_CONST related in the evoab2 driver
Comment 6 Caolan McNamara 2005-07-18 05:24:22 EDT
Tracked this down. Fix is now logged upstream as
http://www.openoffice.org/issues/show_bug.cgi?id=52023. Fixed in rawhide/FC4.

Note You need to log in before you can comment on or make changes to this bug.