Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1474072 - fontconfig-devel provides incorrect includedir in /usr/lib64/pkgconfig/fontconfig.pc
fontconfig-devel provides incorrect includedir in /usr/lib64/pkgconfig/fontco...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
26
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-23 11:14 EDT by Alexandr Kondratev
Modified: 2017-07-23 23:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-23 23:28:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Compilation check (593 bytes, application/x-gzip)
2017-07-23 11:14 EDT, Alexandr Kondratev
no flags Details

  None (edit)
Description Alexandr Kondratev 2017-07-23 11:14:36 EDT
Created attachment 1303238 [details]
Compilation check

Description of problem:
See subj.

Version-Release number of selected component (if applicable):
fontconfig-devel-2.12.1-4.fc26.x86_64


How reproducible:

Steps to Reproduce:
1. dnf install fontconfig-devel
2. # Unpack tarball from attachment. 
3. cd xfontchk
4. make

Actual results:
c99 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/libpng16   -I/usr/include/freetype2 -I/usr/include/libpng16  -DVERSION="0.7" -D_XOPEN_SOURCE=600 -O -c xfontchk.c
xfontchk.c:2:10: fatal error: fontconfig.h: No such file or directory
 #include <fontconfig.h>
          ^~~~~~~~~~~~~~
compilation terminated.
make: *** [Makefile:7: xfontchk.o] Error 1


Expected results:
c99 -I/usr/X11R6/include -I/usr/include/fontconfig -I/usr/include/freetype2 -I/usr/include/libpng16   -I/usr/include/freetype2 -I/usr/include/libpng16  -DVERSION="0.7" -D_XOPEN_SOURCE=600 -O -c xfontchk.c
c99 -L/usr/X11R6/lib -lm -lrt -lX11 -lutil -lXft -lfontconfig -lfreetype  -lfreetype  -o xfontchk xfontchk.o



Additional info:
Due to fontconfig-devel provides only /usr/include/fontconfig folder, the solution is:
$ diff /usr/lib64/pkgconfig/fontconfig.pc{.orig,}
4c4
< includedir=/usr/include
---
> includedir=/usr/include/fontconfig

which give expected result.
Comment 1 Alexandr Kondratev 2017-07-23 11:52:36 EDT
Formatted patch:

--- /usr/lib64/pkgconfig/fontconfig.pc  2017-07-23 17:52:51.844365570 +0300
+++ /usr/lib64/pkgconfig/fontconfig.pc  2017-07-23 18:09:14.221529256 +0300
@@ -1,7 +1,7 @@
 prefix=/usr
 exec_prefix=/usr
 libdir=/usr/lib64
-includedir=/usr/include
+includedir=/usr/include/fontconfig
 sysconfdir=/etc
 localstatedir=/var
 PACKAGE=fontconfig
Comment 2 Akira TAGOH 2017-07-23 23:28:55 EDT
Many applications has #include <fontconfig/fontconfig.h> long time since it has been launched. I won't fix that since this affects so many.

Note You need to log in before you can comment on or make changes to this bug.