Bug 1474105 - pdns fails to build with boost 1.64
pdns fails to build with boost 1.64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jonathan Wakely
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-23 18:11 EDT by Morten Stevens
Modified: 2017-07-24 09:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 06:38:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Morten Stevens 2017-07-23 18:11:38 EDT
Description of problem:

pdns-4.0.4 fails to build with the latest boost 1.64 package.

Buildlogs:
https://koji.fedoraproject.org/koji/buildinfo?buildID=921224

Upstream bug:
https://github.com/PowerDNS/pdns/issues/5547#issuecomment-317249483

Boost bug:
https://svn.boost.org/trac10/ticket/12516 

Maybe we can backport this patch to Fedora:

https://github.com/boostorg/serialization/commit/1d86261581230e2dc5d617a9b16287d326f3e229
Comment 1 Jonathan Wakely 2017-07-24 05:30:25 EDT
I already patch Boost for https://github.com/boostorg/mpi/pull/40 which is due to the same problem. I might even be able to drop that patch after patching Boost.Serialization.
Comment 2 Morten Stevens 2017-07-24 06:07:48 EDT
@Jonathan Wakely 

Okay, it would be nice if we can try patch https://github.com/boostorg/serialization/commit/1d86261581230e2dc5d617a9b16287d326f3e229 to see if it helps to build pdns for Fedora.
Comment 3 Jonathan Wakely 2017-07-24 06:38:28 EDT
Björn Esser already made this change, but without removing the MPI patch. I'll do that cleanup (and change the release to .1) next time I need to change something in boost.

I've confirmed it does fix the pdns build. You can rebuild it when https://koji.fedoraproject.org/koji/buildinfo?buildID=921397 reaches the buildroot.
Comment 4 Björn "besser82" Esser 2017-07-24 07:09:19 EDT
I've removed the obsolete MPI patch in 0.4 build.
Comment 5 Morten Stevens 2017-07-24 09:49:52 EDT
Thank you. It's now building fine :)

Note You need to log in before you can comment on or make changes to this bug.