Bug 1474107 - Conflicts between i686 and x86_64 packages
Conflicts between i686 and x86_64 packages
Status: NEW
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
28
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-23 19:12 EDT by srakitnican
Modified: 2018-05-04 08:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description srakitnican 2017-07-23 19:12:05 EDT
Description of problem: Conflict with new package version where the same was installable without any problems in Fedora 25.


Version-Release number of selected component (if applicable):
mono-core-4.8.0-7.fc26

How reproducible: Always


Steps to Reproduce:
1. dnf install mono-core.i686 mono-core.x86_64

Actual results:
Error: Transaction check error:
  file /usr/lib/mono/4.5/mscorlib.dll conflicts between attempted installs of mono-core-4.8.0-7.fc26.x86_64 and mono-core-4.8.0-7.fc26.i686


Expected results: Both packages installable simultaneously 


Additional info:
http://forums.fedoraforum.org/showthread.php?t=314916
Comment 1 Timotheus Pokorra 2017-07-24 03:00:56 EDT
I checked how it worked on Fedora 25:

rpm -ql mono-core  | grep mscorlib
/usr/lib/mono/4.5/mscorlib.dll
/usr/lib/mono/4.5/mscorlib.dll.mdb
/usr/lib/mono/4.5/mscorlib.dll
/usr/lib/mono/4.5/mscorlib.dll.mdb

rpm -qf /usr/lib/mono/4.5/mscorlib.dll
mono-core-4.4.2-1.fc25.x86_64
mono-core-4.4.2-1.fc25.i686

If I remove one package:
dnf remove mono-core.i686

the file /usr/lib/mono/4.5/mscorlib.dll is still there.

Ok, here is a hint:
https://bugzilla.redhat.com/show_bug.cgi?id=1326157#c8
"they contain the same .mo files which is not a problem if you install the same version of  x86_64 and i686 package (because the files are identical - have the same chackusum). If versions differ so do files (because they contain at least different timestamps) and it (must) generates file conflict."

So it seems, in Mono 4.8 the file mscorlib.dll is compiled differently for 32 and for 64 bit, and therefore cannot be installed in parallel anymore.

I don't know if and how that can be solved. Any ideas? Do we need to use /usr/lib64 etc? But that would mean quite a lot of change.

Are there any other ways you could workaround this issue? Perhaps using linux containers to install the two packages seperately?
Comment 2 srakitnican 2017-07-24 03:25:00 EDT
(In reply to Timotheus Pokorra from comment #1)
> Are there any other ways you could workaround this issue? Perhaps using
> linux containers to install the two packages seperately?

I am not using it, so I am not having any issues with it personally, thus I am not the right person to answer that. Just reporting the issue.
Comment 3 Fedora End Of Life 2018-05-03 04:38:06 EDT
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.
Comment 4 Zoltan Boszormenyi 2018-05-04 08:38:31 EDT
This still occurs on Fedora 28.

Error: Transaction check error:
  file /usr/lib/mono/4.5/mscorlib.dll conflicts between attempted installs of mono-core-4.8.0-12.fc28.x86_64 and mono-core-4.8.0-12.fc28.i686

Note You need to log in before you can comment on or make changes to this bug.