Bug 1474110 - SELinux is preventing gst-plugin-scan from 'create' accesses on the file .glvndZ3nyc4.
SELinux is preventing gst-plugin-scan from 'create' accesses on the file .glv...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:374665139410b4aaabc6b46f2fd...
:
: 1436408 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-23 19:45 EDT by Shane Reynolds
Modified: 2017-11-15 15:11 EST (History)
11 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-260.14.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-15 15:11:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Reynolds 2017-07-23 19:45:23 EDT
Description of problem:
SELinux is preventing gst-plugin-scan from 'create' accesses on the file .glvndZ3nyc4.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gst-plugin-scan should be allowed create access on the .glvndZ3nyc4 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gst-plugin-scan' --raw | audit2allow -M my-gstpluginscan
# semodule -X 300 -i my-gstpluginscan.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                .glvndZ3nyc4 [ file ]
Source                        gst-plugin-scan
Source Path                   gst-plugin-scan
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-259.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.9-300.fc26.x86_64 #1 SMP Wed
                              Jul 5 16:21:56 UTC 2017 x86_64 x86_64
Alert Count                   2
First Seen                    2017-07-13 22:41:18 CDT
Last Seen                     2017-07-14 13:04:58 CDT
Local ID                      dbdeef15-9edc-4a31-bd93-4ff030b71fe0

Raw Audit Messages
type=AVC msg=audit(1500055498.442:275): avc:  denied  { create } for  pid=7956 comm="gst-plugin-scan" name=".glvndZ3nyc4" scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file permissive=0


Hash: gst-plugin-scan,thumb_t,user_home_dir_t,file,create

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.10-300.fc26.x86_64
type:           libreport

Potential duplicate: bug 1436408
Comment 1 GOGI 2017-10-20 20:02:16 EDT
Description of problem:
This error appeared after a system cleaning with BleachBit, actually I deleted all the "Thumbs.db" files, cleaned caches, etc... 
So I suppose that tracker had to rebuild some db files for miniatures, when I opened Nautilus in a path containing icons, and got then this alert.

Version-Release number of selected component:
selinux-policy-3.13.1-260.13.fc26.noarch

Additional info:
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.13.5-200.fc26.x86_64
type:           libreport
Comment 2 Lukas Vrabec 2017-10-22 09:00:01 EDT
*** Bug 1436408 has been marked as a duplicate of this bug. ***
Comment 3 Lukas Vrabec 2017-10-22 09:29:11 EDT
If you saw this AVC, was something broken on your system? Or you just saw the AVC? 

Lukas.
Comment 4 GOGI 2017-10-22 10:26:07 EDT
(In reply to Lukas Vrabec from comment #3)
> If you saw this AVC, was something broken on your system? Or you just saw
> the AVC? 
> 
> Lukas.

IF the question is for me, as far as I know nothing is broken on my system and everything is up to date. The AVC appeared as I said, when I did some cleaning with BleachBit and then opened Nautilus in a path with icons (i.e /usr/share/themes/* )
Comment 5 Fedora Update System 2017-10-26 08:32:02 EDT
selinux-policy-3.13.1-260.14.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d312739a4e
Comment 6 Fedora Update System 2017-11-15 15:11:21 EST
selinux-policy-3.13.1-260.14.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.