This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 14742 - IPX modules not loaded
IPX modules not loaded
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-27 14:34 EDT by Yan Fitterer
Modified: 2014-03-16 22:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-27 14:34:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yan Fitterer 2000-07-27 14:34:01 EDT
When modules ipx and ncpfs are not compiled in the kernel, they need
to be loaded during the init scripts.

The network init script (/etc/rc.d/init.d/network) is attempting to do
things with ipx, and fails due to the modules not being loaded.

For info, here are the lines I've added in my /etc/rc.d/rc.sysinit - I'm
sure this is the "wrong" way of doing it, but it does the job for me... ;)

# Load Netware modules if required
alias=`egrep -s "^alias[[:space:]]+nw_net[[:space:]]+" /etc/conf.modules |
awk '{print $3}'`
if [ -n $alias -a $alias != "off" ] ; then
   action "Loading $alias module" modprobe $alias
fi
alias=`egrep -s "^alias[[:space:]]+nw_fs[[:space:]]+" /etc/conf.modules |
awk '{print $3}'`
if [ -n $alias -a $alias != "off" ] ; then
   action "Loading $alias module" modprobe $alias
fi

Of course I have added the following two lines to /etc/conf.modules:
alias nw_net ipx
alias nw_fs ncpfs

Hope I haven't made a fool of myself... :(
Comment 1 Bill Nottingham 2000-07-27 15:05:01 EDT
You need to just add:

alias net-pf-4 ipx

to /etc/conf.modules and it will get loaded automatically.

This is fixed in the modutils currently in rawhide.

Note You need to log in before you can comment on or make changes to this bug.