Bug 1474277 - Node status should become "Unknow" after stop node service
Node status should become "Unknow" after stop node service
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
3.6.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Avesh Agarwal
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 05:49 EDT by Zhang Cheng
Modified: 2017-07-24 16:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 16:04:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhang Cheng 2017-07-24 05:49:07 EDT
Description of problem: Node status have been updated to "Unknown" in yaml, but didn't update in oc command line after stop node service.


Version-Release number of selected component (if applicable):
openshift v3.6.153


How reproducible:
Always


Steps to Reproduce:
1. Step up a cluster with at least one ready node:
# oc get node
NAME                                                STATUS                     AGE       VERSION
host-8-172-64.host.centralci.eng.rdu2.redhat.com    Ready,SchedulingDisabled   1h        v1.6.1+5115d708d7
host-8-174-67.host.centralci.eng.rdu2.redhat.com    Ready                   1h        v1.6.1+5115d708d7
host-8-175-183.host.centralci.eng.rdu2.redhat.com   Ready                      1h        v1.6.1+5115d708d7

2. Stop node service on host host-8-174-67.host.centralci.eng.rdu2.redhat.com
# systemctl stop atomic-openshift-node

3. Check node status for host host-8-174-67.host.centralci.eng.rdu2.redhat.com
# oc get node
# oc get node host-8-174-67.host.centralci.eng.rdu2.redhat.com -o yaml


Actual results: Node host-8-174-67.host.centralci.eng.rdu2.redhat.com status have been updated to "Unknown" in yaml, but didn't update in oc command line.
3. Check node status for host host-8-174-67.host.centralci.eng.rdu2.redhat.com
# oc get node
NAME                                                STATUS                     AGE       VERSION
host-8-172-64.host.centralci.eng.rdu2.redhat.com    Ready,SchedulingDisabled   1h        v1.6.1+5115d708d7
host-8-174-67.host.centralci.eng.rdu2.redhat.com    NotReady                   1h        v1.6.1+5115d708d7
host-8-175-183.host.centralci.eng.rdu2.redhat.com   Ready                      1h        v1.6.1+5115d708d7

# oc get node host-8-174-67.host.centralci.eng.rdu2.redhat.com -o yaml
... ...
  - lastHeartbeatTime: 2017-07-24T09:31:54Z
    lastTransitionTime: 2017-07-24T09:32:36Z
    message: Kubelet stopped posting node status.
    reason: NodeStatusUnknown
    status: Unknown
    type: Ready


Expected results: 
# Node host-8-174-67.host.centralci.eng.rdu2.redhat.com status should become "Unknown" both in yaml file and `oc get node`.


addition info: 
None.
Comment 1 Derek Carr 2017-07-24 12:39:32 EDT
Avesh - please take a look at what oc get printers for nodes are doing here.
Comment 2 Avesh Agarwal 2017-07-24 12:44:07 EDT
sure, going to look into soon.
Comment 3 Jordan Liggitt 2017-07-24 12:49:42 EDT
if the Ready condition is anything other than True, the summarizing printer outputs "NotReady"
Comment 4 Jordan Liggitt 2017-07-24 16:04:36 EDT
I don't think this is a bug... the `oc get` output is intended to print "Ready" if the Ready condition is True, and NotReady otherwise.

Note You need to log in before you can comment on or make changes to this bug.