Bug 1474287 - engine-cleanup fails on LooseVersion not having attribute 'version'
engine-cleanup fails on LooseVersion not having attribute 'version'
Status: CLOSED CURRENTRELEASE
Product: otopi
Classification: oVirt
Component: Plugins.core (Show other bugs)
1.7.0
All All
unspecified Severity high (vote)
: ovirt-4.2.0
: 1.7.1
Assigned To: Yedidyah Bar David
Lukas Svaty
: AutomationBlocker, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 06:21 EDT by Lukas Svaty
Modified: 2017-12-20 06:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:31:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79743 None None None 2017-07-25 03:25 EDT

  None (edit)
Description Lukas Svaty 2017-07-24 06:21:42 EDT
Description of problem:
Engine-cleanup utility fails to execute on latest master.
Exception from log:

2017-07-24 13:15:42,265+0300 DEBUG otopi.context context._executeMethod:142 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 132, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-remove/base/core/misc.py", line 112, in _setup
    osetupcons.CoreEnv.ORIGINAL_GENERATED_BY_VERSION
AttributeError: LooseVersion instance has no attribute 'version'


Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20170723141021.git463826a.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run engine-cleanup on engine that was previously set up\

Actual results:
engine-setup fails

Expected results:
should succeed

Additional info:
Adding severity high, as this is blocking our ansible repository for integration tools.
https://travis-ci.org/rhevm-qe-automation/ovirt-ansible/jobs/256601531

Output of engine-cleanup:
[root@system-ge ~]# engine-cleanup 
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-remove-20170724131541-iwc6rd.log
          Version: otopi-1.7.1_master (otopi-1.7.1-0.0.master.20170720151120.git5879c4e.el7.centos)
[ ERROR ] Failed to execute stage 'Environment setup': LooseVersion instance has no attribute 'version'
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-remove-20170724131541-iwc6rd.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20170724131542-cleanup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of cleanup failed
Comment 1 Red Hat Bugzilla Rules Engine 2017-07-25 02:35:54 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Yedidyah Bar David 2017-07-25 03:18:51 EDT
Is it still failing? Perhaps it's now fixed, by [1]? Didn't verify myself yet.

[1] https://gerrit.ovirt.org/79743
Comment 3 Yedidyah Bar David 2017-07-25 03:25:18 EDT
Now verified, seems to be solved. Moving to MODIFIED, not sure what's the exact process - we'll probably move to QE only later.
Comment 4 Lukas Svaty 2017-07-27 07:16:33 EDT
verified in ovirt-engine-4.2.0-0.0.master.20170726123301.gitafc8eb1.el7.centos.noarch
Comment 5 Sandro Bonazzola 2017-12-20 06:31:55 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.