Bug 1474442 - crypto-policies rawhide builds fail
crypto-policies rawhide builds fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: crypto-policies (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikos Mavrogiannopoulos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 11:40 EDT by Troy Dawson
Modified: 2017-07-25 03:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 03:16:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix crypto-policies libdir path (2.98 KB, patch)
2017-07-24 12:50 EDT, Troy Dawson
no flags Details | Diff

  None (edit)
Description Troy Dawson 2017-07-24 11:40:47 EDT
Description of problem:
crypto-policies is currently failling builds on rawhide.
I believe this is due to the newer version in Perl that was added.

Version-Release number of selected component (if applicable):
crypto-policies-20170606-1.git7c32281.fc27

How reproducible:
100%

Steps to Reproduce:
1. koji build --scratch rawhide crypto-policies-20170606-1.git7c32281.fc27.src.rpm
2.
3.

Actual results:
...
install -p -m 644 default-config /builddir/build/BUILDROOT/crypto-policies-20170606-1.git7c32281.fc27.noarch//usr/share/crypto-policies
./generate-policies.pl /builddir/build/BUILDROOT/crypto-policies-20170606-1.git7c32281.fc27.noarch//usr/share/crypto-policies
Can't locate back-ends//gnutls.pl in @INC (@INC contains: back-ends/ /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5) at ./generate-policies.pl line 23.
make: *** [Makefile:16: install] Error 2
...

Expected results:
rpm to build

Additional info:
Here is an example of a failed scratch build.
https://koji.fedoraproject.org/koji/taskinfo?taskID=20713970

I believe this is due to the setting of libdir in generate-policies.pl
It needs to be ./back-ends/ instead of just back-ends/
Comment 1 Troy Dawson 2017-07-24 12:50 EDT
Created attachment 1303772 [details]
Patch to fix crypto-policies libdir path

I have attached a patch to fix the libdir path for the new perl.

Here is a successful rawhide scratch build with the patch applied.
https://koji.fedoraproject.org/koji/taskinfo?taskID=20714647
Comment 2 Troy Dawson 2017-07-24 12:51:50 EDT
But this failed build is blocking some automated building for the bootstrap and module team.

I understand that time is important and that not everyone has time to work on failed builds.
If you are unable to update the rpm within two weeks, we will have a proven packager apply the patch in this bug.
If you know you will be too busy and wouldn't mind us applying it sooner, just let us know.
Comment 3 Nikos Mavrogiannopoulos 2017-07-25 02:55:15 EDT
https://gitlab.com/nmav/fedora-crypto-policies/merge_requests/4
Comment 4 Nikos Mavrogiannopoulos 2017-07-25 02:55:56 EDT
Sent build to koji: https://koji.fedoraproject.org/koji/taskinfo?taskID=20719411

Note You need to log in before you can comment on or make changes to this bug.