Bug 1474472 - exception on ui.log (unknown cause) @ dataprovider.AsyncDataProvider.$initCpuMapForVersion
exception on ui.log (unknown cause) @ dataprovider.AsyncDataProvider.$initCpu...
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.1.2.1
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 13:38 EDT by Yaniv Kaul
Modified: 2017-10-09 03:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-09 03:41:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2017-07-24 13:38:53 EDT
Description of problem:
Seen on RHEV.TLV:
2017-07-21 13:27:43,718+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-103) [] Permutation name: FD70F8A950E8BCDADFEFA18A3E17F23A
2017-07-21 13:27:43,718+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-103) [] Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: c is undefined
        at org.ovirt.engine.ui.uicommonweb.dataprovider.AsyncDataProvider.$initCpuMapForVersion(AsyncDataProvider.java:419)
        at org.ovirt.engine.ui.uicommonweb.dataprovider.AsyncDataProvider$5.executed(AsyncDataProvider.java:406)
        at org.ovirt.engine.ui.frontend.Frontend$3.$onSuccess(Frontend.java:328) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.Frontend$3.onSuccess(Frontend.java:328) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.OperationProcessor$3.$onSuccess(OperationProcessor.java:176) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.OperationProcessor$3.onSuccess(OperationProcessor.java:176) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.GWTRPCCommunicationProvider$5$1.$onSuccess(GWTRPCCommunicationProvider.java:269) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.GWTRPCCommunicationProvider$5$1.onSuccess(GWTRPCCommunicationProvider.java:269) [frontend.jar:]
        at com.google.gwt.user.client.rpc.impl.RequestCallbackAdapter.onResponseReceived(RequestCallbackAdapter.java:198) [gwt-servlet.jar:]
        at com.google.gwt.http.client.Request.$fireOnResponseReceived(Request.java:237) [gwt-servlet.jar:]
        at com.google.gwt.http.client.RequestBuilder$1.onReadyStateChange(RequestBuilder.java:409) [gwt-servlet.jar:]
        at Unknown.TMd/c.onreadystatechange<(Unknown Source)
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
        at Unknown.Rt/<(Unknown Source)
        at Unknown.anonymous(Unknown Source

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-debuginfo-4.1.2.1-0.1.el7.noarch
ovirt-engine-webadmin-portal-4.1.2.1-0.1.el7.noarch
Comment 2 Michal Skrivanek 2017-07-25 00:38:55 EDT
Anything you've been clicking on? Right after login?
Comment 3 Yaniv Kaul 2017-07-25 02:00:13 EDT
(In reply to Michal Skrivanek from comment #2)
> Anything you've been clicking on? Right after login?

That's what 'unknown cause' in the title referred to - it's just what I've seen in the logs.
Comment 4 Tomas Jelinek 2017-08-01 06:59:31 EDT
What happens here is that frontend calls the GetAllServerCpuListQuery for all versions. If one of this queries returns null, the frontend fails on NPE. 

I don't see any way how the server could return null, so had to be something strange, like logout in the middle or something like that.

Any chance to see also the server logs from the same time to see what happened there?
Comment 6 Tomas Jelinek 2017-10-09 03:41:30 EDT
I can not simulate it and I have not seen anything suspicious in the logs. But it sounds harmless - if the backend is in a state that it does not return anything (e.g. logout), it is not a problem that also frontend does not show anything. My suspicion is that the webadmin just redirected to login page right after (or during) the exception happend.

I will close it now since I guess it would be quite time consuming to find the exact issue and I don't think the issue is important enough to dig too deep into it. Please feel free to reopen if you think otherwise.

Note You need to log in before you can comment on or make changes to this bug.