Bug 1474477 - exception on ui.log (unknown cause) @ models.hosts.FenceProxyModel.executeCommand(FenceProxyModel.java:88)
exception on ui.log (unknown cause) @ models.hosts.FenceProxyModel.executeCom...
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.1.2.1
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Eli Mesika
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 13:45 EDT by Yaniv Kaul
Modified: 2017-07-30 04:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-30 04:27:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2017-07-24 13:45:55 EDT
Description of problem:
Seen on RHEV.TLV:
2017-07-17 22:48:32,512+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-236) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (Ty
peError) 
 __gwt$exception: <skipped>: Cannot read property 'c' of null
        at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_131]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_131]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.event.dom.client.DomEvent.fireNativeEvent(DomEvent.java:110) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.CustomButton.onBrowserEvent(CustomButton.java:631) [gwt-servlet.jar:]
        at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1648) [gwt-servlet.jar:]
        at com.google.gwt.user.client.impl.DOMImplStandard.dispatchEvent(DOMImplStandard.java:320) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
        at Unknown.eval(webadmin-0.js@54)
        at com.google.gwt.dom.client.DOMImplStandard.$dispatchEvent(DOMImplStandard.java:68) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.CustomButton.$onClick(CustomButton.java:822) [gwt-servlet.jar:]
        at org.ovirt.engine.ui.common.widget.dialog.AbstractDialogButton.onClick(AbstractDialogButton.java:45)
        at com.google.gwt.user.client.ui.CustomButton.onBrowserEvent(CustomButton.java:631) [gwt-servlet.jar:]
        at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1648) [gwt-servlet.jar:]
        at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1666) [gwt-servlet.jar:]
        at com.google.gwt.user.client.impl.DOMImplStandard.dispatchCapturedMouseEvent(DOMImplStandard.java:352) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
        at Unknown.eval(webadmin-0.js@54)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'c' of null
        at org.ovirt.engine.ui.uicommonweb.models.hosts.FenceProxyModel.executeCommand(FenceProxyModel.java:88)
        at org.ovirt.engine.ui.uicommonweb.UICommand.$execute(UICommand.java:163)
        at org.ovirt.engine.ui.common.presenter.AbstractModelBoundPopupPresenterWidget$6.onClick(AbstractModelBoundPopupPresenterWidget.java:357)
        at com.google.gwt.event.dom.client.ClickEvent.dispatch(ClickEvent.java:55) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
        at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
        ... 21 more


Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-debuginfo-4.1.2.1-0.1.el7.noarch
ovirt-engine-webadmin-portal-4.1.2.1-0.1.el7.noarch

Note You need to log in before you can comment on or make changes to this bug.