Bug 1474607 - [RFE] Add gnocchi support for neutron meters. [NEEDINFO]
[RFE] Add gnocchi support for neutron meters.
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-gnocchi (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
low Severity low
: ---
: 10.0 (Newton)
Assigned To: Mehdi ABAAKOUK
Sasha Smolyak
: FutureFeature, Triaged, ZStream
Depends On:
Blocks: 1473146
  Show dependency treegraph
 
Reported: 2017-07-24 23:07 EDT by Martin Lopes
Modified: 2017-10-12 10:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-12 10:17:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mabaakou: needinfo? (kiyyappa)


Attachments (Terms of Use)

  None (edit)
Description Martin Lopes 2017-07-24 23:07:47 EDT
Customers might expect to have gnocchi support for neutron meters. For example, the ingress and egress meters should be available within gnocchi:

----
neutron meter-label-rule-create neutron-egress 172.24.0.0/24 --direction egress --tenant-id 19baa2ae26a246ch840b6c036320031e
----
Comment 1 Mehdi ABAAKOUK 2017-07-31 10:19:56 EDT
It seems you are looking for the already existing 'bandwidth' meter.

To get the resource info in Gnocchi:

$ openstack metric resource search --type network 'resource_id="<label_id>"'

To get the measure :

$ openstack metric measures show --resource <label_id> bandwidth
Comment 2 Mehdi ABAAKOUK 2017-07-31 10:21:55 EDT
Tell me if that match your need ? If yes I will close this RFE
Comment 9 Mehdi ABAAKOUK 2017-10-12 10:17:32 EDT
I close the bug since the answer of the question is in comment 6.

Feel free to reopen or open a new bug for more support.

Note You need to log in before you can comment on or make changes to this bug.