Bug 1474758 - undercloud installation failed on dependencies Error: Execution of '/bin/yum -d 0 -e 0 -y install rabbitmq-server' returned 1: Error: Package: erlang-crypto-18.3.4.5-4.el7ost.x86_64 (rhelosp-12.0-puddle)
undercloud installation failed on dependencies Error: Execution of '/bin/yum ...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Slagle
Arik Chernetsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 06:54 EDT by Ronnie Rasouli
Modified: 2017-07-25 07:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 07:00:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum.log from the setup (50.40 KB, text/plain)
2017-07-25 06:54 EDT, Ronnie Rasouli
no flags Details
undercloud installation log (260.78 KB, text/plain)
2017-07-25 06:58 EDT, Ronnie Rasouli
no flags Details

  None (edit)
Description Ronnie Rasouli 2017-07-25 06:54:38 EDT
Created attachment 1304168 [details]
yum.log from the setup

Description of problem:
Undercloud installation failed due to dependencies error

14:57:51 stdout: 2017-07-24 07:40:41,330 INFO: Notice: /Stage[setup]/Tripleo::Network::Os_net_config/Exec[os-net-config]/returns: executed successfully
14:57:51 2017-07-24 07:40:41,337 INFO: Notice: /Stage[setup]/Tripleo::Network::Os_net_config/Exec[trigger-keepalived-restart]: Triggered 'refresh' from 1 events
14:57:51 2017-07-24 07:40:43,112 INFO: Error: Execution of '/bin/yum -d 0 -e 0 -y install rabbitmq-server' returned 1: Error: Package: erlang-crypto-18.3.4.5-4.el7ost.x86_64 (rhelosp-12.0-puddle)
14:57:51 2017-07-24 07:40:43,112 INFO:            Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
14:57:51 2017-07-24 07:40:43,112 INFO:  You could try using --skip-broken to work around the problem
14:57:51 2017-07-24 07:40:43,112 INFO:  You could try running: rpm -Va --nofiles --nodigest
14:57:51 2017-07-24 07:40:43,112 INFO: Error: /Stage[main]/Rabbitmq::Install/Package[rabbitmq-server]/ensure: change from purged to present failed: Execution of '/bin/yum -d 0 -e 0 -y install rabbitmq-server' returned 1: Error: Package: erlang-crypto-18.3.4.5-4.el7ost.x86_64 (rhelosp-12.0-puddle)
14:57:51 2017-07-24 07:40:43,112 INFO:            Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
14:57:51 2017-07-24 07:40:43,112 INFO:  You could try using --skip-broken to work around the problem
14:57:51 2017-07-24 07:40:43,113 INFO:  You could try running: rpm -Va --nofiles --nodigest
14:57:51 2017-07-24 07:40:43,113 INFO: Notice: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq]: Dependency Package[rabbitmq-server] has failures: true
14:57:51 2017-07-24 07:40:43,113 INFO: Warning: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq]: Skipping because of failed dependencies
14:57:51 --
14:57:51 2017-07-24 07:43:23,120 INFO: Notice: /Stage[main]/Mistral::Engine/Mistral_config[execution_expiration_policy/older_than]/ensure: created
14:57:51 2017-07-24 07:43:25,927 INFO: Notice: /Stage[main]/Tripleo::Ui/Package[openstack-tripleo-ui]/ensure: created
14:57:51 2017-07-24 07:43:27,588 INFO: Error: Execution of '/bin/yum -d 0 -e 0 -y install openstack-tripleo-validations' returned 1: Error: Package: openstack-tripleo-validations-7.1.1-0.20170717141229.ce35d5f.el7ost.noarch (rhelosp-12.0-puddle)
14:57:51 2017-07-24 07:43:27,588 INFO:            Requires: ansible >= 2
14:57:51 2017-07-24 07:43:27,588 INFO:  You could try using --skip-broken to work around the problem
14:57:51 2017-07-24 07:43:27,588 INFO:  You could try running: rpm -Va --nofiles --nodigest
14:57:51 2017-07-24 07:43:27,588 INFO: Error: /Stage[main]/Tripleo::Profile::Base::Validations/Package[openstack-tripleo-validations]/ensure: change from purged to present failed: Execution of '/bin/yum -d 0 -e 0 -y install openstack-tripleo-validations' returned 1: Error: Package: openstack-tripleo-validations-7.1.1-0.20170717141229.ce35d5f.el7ost.noarch (rhelosp-12.0-puddle)
14:57:51 2017-07-24 07:43:27,588 INFO:            Requires: ansible >= 2
14:57:51 2017-07-24 07:43:27,589 INFO:  You could try using --skip-broken to work around the problem
14:57:51 2017-07-24 07:43:27,589 INFO:  You could try running: rpm -Va --nofiles --nodigest
14:57:51 2017-07-24 07:43:27,608 INFO: Notice: /Stage[main]/Tripleo::Profile::Base::Validations/User[validations]/ensure: created
14:57:51 2017-07-24 07:43:36,073 INFO: Notice: /Stage[main]/Zaqar/Package[zaqar-common]/ensure: created
14:57:51 --
14:57:51 2017-07-24 07:49:41,831 INFO: Notice: /Stage[main]/Keystone::Db::Sync/Exec[keystone-manage db_sync]: Triggered 'refresh' from 3 events
14:57:51 2017-07-24 07:49:41,832 INFO: Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::dbsync::end]: Triggered 'refresh' from 2 events
14:57:51 2017-07-24 07:54:41,835 INFO: Error: /Stage[main]/Keystone/Exec[keystone-manage bootstrap]: Failed to call refresh: Command exceeded timeout
14:57:51 2017-07-24 07:54:41,836 INFO: Error: /Stage[main]/Keystone/Exec[keystone-manage bootstrap]: Command exceeded timeout
14:57:51 2017-07-24 07:54:41,836 INFO: Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::begin]: Triggered 'refresh' from 5 events
14:57:51 2017-07-24 07:54:41,838 INFO: Error: /Stage[main]/Rabbitmq/Rabbitmq_plugin[rabbitmq_management]: Provider rabbitmqplugins is not functional on this host
14:57:51 2017-07-24 07:54:41,839 INFO: Notice: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Dependency Package[rabbitmq-server] has failures: true
14:57:51 2017-07-24 07:54:41,839 INFO: Notice: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Dependency Rabbitmq_plugin[rabbitmq_management] has failures: true
14:57:51 2017-07-24 07:54:41,839 INFO: Warning: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Skipping because of failed dependencies
14:57:51 2017-07-24 07:54:41,840 INFO: Notice: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Dependency Package[rabbitmq-server] has failures: true
14:57:51 2017-07-24 07:54:41,840 INFO: Notice: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Dependency Rabbitmq_plugin[rabbitmq_management] has failures: true
14:57:51 --
14:57:51 2017-07-24 07:54:41,841 INFO: Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Dependency Package[rabbitmq-server] has failures: true
14:57:51 2017-07-24 07:54:41,841 INFO: Warning: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Skipping because of failed dependencies
14:57:51 2017-07-24 07:57:34,517 INFO: Error: Failed to apply catalog: Execution of '/bin/openstack role list --quiet --format csv' returned 1: Unable to establish connection to http://192.168.24.1:35357/v3/roles?: HTTPConnectionPool(host='192.168.24.1', port=35357): Max retries exceeded with url: /v3/roles (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x4d14150>: Failed to establish a new connection: [Errno 111] Connection refused',)) (tried 47, for a total of 170 seconds)
14:57:51 2017-07-


full log in  http://10.35.4.236:8080/view/DFG/view/cloud-apps/view/heat/job/DFG-cloud-apps-heat-12_director-7.4-virthost-heat-regression-tests/5/consoleFull

Version-Release number of selected component (if applicable):
RHOS12 

instack-undercloud-7.1.1-0.20170714211622.el7ost.noarch

How reproducible:
Deploy RHOS12 with 1 undercloud, 1 controller 2 compute 

Steps to Reproduce:
1.
2.
3.

Actual results:
Error in undercloud installation step

Expected results:


Additional info:

Please use the link above of the CI job to collect all the relevant info
Comment 1 Ronnie Rasouli 2017-07-25 06:58 EDT
Created attachment 1304169 [details]
undercloud installation log
Comment 2 Alan Pevec 2017-07-25 07:00:30 EDT
Error: Execution of '/bin/yum -d 0 -e 0 -y install rabbitmq-server' returned 1: Error: Package: erlang-crypto-18.3.4.5-4.el7ost.x86_64 (rhelosp-12.0-puddle)
            Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
openssl 1.0.2 is 7.4 and osp12 is 7.4 only
so this job is invalid, it has rhos-release-rhel-7.3.repo in yum.repos.d

Note You need to log in before you can comment on or make changes to this bug.