This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1474828 - Misleading description in section 21.9 Persistent Storage using Fibre Channel
Misleading description in section 21.9 Persistent Storage using Fibre Channel
Status: CLOSED DUPLICATE of bug 1474839
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Gaurav Nelson
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 09:22 EDT by Pierangelo Magli
Modified: 2017-10-03 01:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-03 01:16:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierangelo Magli 2017-07-25 09:22:42 EDT
Document URL: https://access.redhat.com/documentation/en-us/openshift_container_platform/3.5/html-single/installation_and_configuration/#install-config-persistent-storage-persistent-storage-fibre-channel

Section Number and Name: 21.9.2 Provisioning (sub-section of 21.9 Persistent Storage using Fibre Channel)

Describe the issue: Both the text and the example provided in this section are misleading. The text states: "Note, the number of LUNs must correspond to the number of Persistent Volumes that are created. In the example below, we have LUN as 2, therefore we have created two Persistent Volume definitions." and then in the pictures below there are 2 PVs shown, both backed by LUN 2.
However, the text above does not make sense... The LUN parameter in the YAML description is the LUN ID, which is defined by the SAN administrator when the LUN is created. Suppose the SAN admin gives us a LUN with ID = 100. Does that mean, citing the sentence above, that "we have LUN as 100, therefore we have created 100 PV definitions"?

Suggestions for improvement: I would remove the text "In the example below, we have LUN as 2, therefore we have created two Persistent Volume definitions.", and remove also the second picture (i.e. the one referencing pv0002). Then, I would stress that there is a 1-1 mapping between a persistent volume and a LUN (it's stated later in section 21.9.2.1. ENFORCING DISK QUOTAS).

Additional information:
Comment 1 Gaurav Nelson 2017-10-03 01:16:57 EDT

*** This bug has been marked as a duplicate of bug 1474839 ***

Note You need to log in before you can comment on or make changes to this bug.