Bug 1474871 - Ansible scaleup playbook fails on Install the base package for versioning
Ansible scaleup playbook fails on Install the base package for versioning
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.5.0
Unspecified Unspecified
medium Severity high
: ---
: 3.7.0
Assigned To: Jan Chaloupka
Johnny Liu
: UpcomingRelease
Depends On:
Blocks: 1484142 1484144
  Show dependency treegraph
 
Reported: 2017-07-25 10:28 EDT by Vladislav Walek
Modified: 2017-08-25 07:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1484142 1484144 (view as bug list)
Environment:
Last Closed: 2017-08-25 07:16:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladislav Walek 2017-07-25 10:28:32 EDT
Description of problem:

Hello,

the scaleup playbook fails on TASK [openshift_common : Install the base package for versioning] with error message:

MSG:

No package matching 'atomic-openshift-' found available, installed or updated

fatal: [master.node.example.com]: FAILED! => {
    "changed": false, 
    "failed": true, 
    "rc": 126, 
    "results": [
        "No package matching 'atomic-openshift-' found available, installed or updated"
    ]
}

The problem is that it fails running the task on every master, not on the new node. The excluder packages are installed correctly.
Customer did a workaround by updating the task playbook:

name: "{{ openshift.common.service_type }}-docker-excluder{{ openshift_pkg_version | default('') | oo_image_tag_to_rpm_version(include_dash=True) +  '*' }}"

to 
name: "{{ openshift.common.service_type }}-docker-excluder-*"

Unfortunately, he hit another issue:
TASK [openshift_common : Install the base package for versioning] **************
task path: /usr/share/ansible/openshift-ansible/roles/openshift_common/tasks/main.yml:44
fatal: [master.node.example.com]: FAILED! => {
    "failed": true
}

MSG:

|failed expects a string or unicode

Version-Release number of selected component (if applicable):
OpenShift Container Platfrom 3.5
atomic-openshift-docker-excluder-3.5.5.8-1.git.0.1a85a97.el7.noarch
atomic-openshift-excluder-3.5.5.8-1.git.0.1a85a97.el7.noarch

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:


Description of problem:

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag
Comment 12 Jan Chaloupka 2017-07-28 08:43:11 EDT
Upstream PR https://github.com/openshift/openshift-ansible/pull/4925 fixing the case when the openshift_version is set to an empty string.

Note You need to log in before you can comment on or make changes to this bug.