Bug 147488 - license is MIT/X-style, not MPL
license is MIT/X-style, not MPL
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ivana Varekova
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-08 10:07 EST by Matthew Miller
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 09:38:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2005-02-08 10:07:58 EST
Description of problem:

When I saw that the license for this was MPL, I started to go read up
on the Mozilla public license to figure out what that meant for
linking with GPL'd programs, etc.

But then I read the actual copying statement, and found the big
section in their FAQ dealing with this
http://curl.haxx.se/docs/faq.html#6.1 and discovered that the RPM
contains the wrong information, and that the license is simplying
new-BSD (i.e. MIT/X) style.


Version-Release number of selected component (if applicable):

curl-7.12.3-1


How reproducible:
Always

Steps to Reproduce:
look at spec file

Actual Results:  says "License: MPL"

Expected Results:  Should say "License: MIT/X-style"
Comment 1 Daniel Stenberg 2005-02-13 17:39:00 EST
curl has been released under a MIT/X derivate license since 7.10,
October 2002.
Comment 2 Matthew Miller 2005-02-13 22:07:46 EST
And 7.9 looks like it was dual MIT/X-ish and MPL. For what it's worth. :)
Comment 3 Ivana Varekova 2005-04-26 09:38:56 EDT
Thank you for your notice.
This problem is fixed in curl-7.13.1-2. (Thanks Joe Orton.)
Ivana Varekova

Note You need to log in before you can comment on or make changes to this bug.