Bug 147494 - perl ppp and ppc64 overwrite each other during install
perl ppp and ppc64 overwrite each other during install
Status: CLOSED DUPLICATE of bug 144723
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: perl (Show other bugs)
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Chip Turner
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-02-08 10:47 EST by James Bottomley
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-08 13:38:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Bottomley 2005-02-08 10:47:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The ISO images for RHEL3U4 for ppc contain two perl packages on CD2:


However the binaries in both packages install in exactly the same
location (/usr/bin).  During an OS install, *both* packages are
installed, so the last one installed wins the width game.  This means
that perl on ppc (at least on a default install) is always a 64 bit

All our perl XSUBs fail because they're 32 bit.

The problem really illustrates that no-one thought about the width of
binaries with dynamic links problem when coming up with the
lib32/lib64 scheme.

The best solution would seem to be *only* install the 32 bit perl but
let the user overwrite it with the 64 bit perl if really necessary
(and that would be only if they have a perl program that needs access
to the >4GB memory).  The reason being that the binary width on ppc is
predominantly 32 bit, so the principle of least surprise says that
perl should be 32 by default too.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Do a full install
2. file /usr/bin/perl

Actual Results:  Shows that perl is 64 bit

Expected Results:  should be a 32 bit binary

Additional info:
Comment 3 Suzanne Hillman 2005-02-08 13:38:58 EST
This is intended to be resolved for the next update.

In the meantime, removing the ppc64 perl package and up2dating should resolve
your immediate problem.

I'm going to close this as duplicate against the internal bug relating to this
problem. If the information above does not resolve the immediate problem, please
reopen with additional information.

*** This bug has been marked as a duplicate of 144723 ***

Note You need to log in before you can comment on or make changes to this bug.