Bug 1475009 - Enhance glibc.spec to work with new rpm debuginfo generation
Enhance glibc.spec to work with new rpm debuginfo generation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 16:27 EDT by Igor Gnatenko
Modified: 2017-07-27 12:42 EDT (History)
8 users (show)

See Also:
Fixed In Version: glibc-2.25.90-28.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 12:42:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Gnatenko 2017-07-25 16:27:50 EDT
With RPM 4.14 (https://fedoraproject.org/wiki/Changes/RPM-4.14) there are a lot of enhancements in debuginfo generation. Would be nice if you could look at all new options you would like to use and either just switch to use RPM's default debuginfo generation with some custom (or even default) options or if there is some limitation don't hesitate to report bug against RPM and we will try to fix it.

Related announcement of new features: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/ITJHJTUO2WFEAYIHANSM6AMAB5SIFASI/
Related debuginfo improvements: https://fedoraproject.org/wiki/Changes/ParallelInstallableDebuginfo + https://fedoraproject.org/wiki/Changes/SubpackageAndSourceDebuginfo

For now I would like to ask you to add few lines in glibc.spec so that new behavior will not be (or, rather, should not be) inherited during mass rebuild:

diff --git a/glibc.spec b/glibc.spec
index 5392438..509e830 100644
--- a/glibc.spec
+++ b/glibc.spec
@@ -761,6 +761,8 @@ If unsure if you need this, don't install this package.
 %define debug_package %{nil}
 %define __debug_install_post %{nil}
 %global __debug_package 1
+%undefine _debugsource_packages
+%undefine _debuginfo_subpackages
 
 %package debuginfo
 Summary: Debug information for package %{name}


This should make glibc debuginfo thing to be same as it is nowadays.
Comment 1 Carlos O'Donell 2017-07-26 08:07:23 EDT
Igor,

I'm looking into this and will try to test and commit a fix before the end of the day.
Comment 2 Carlos O'Donell 2017-07-27 08:48:25 EDT
The suggest fix seems to work fine with the feature turned on
e.g. 
%global _debugsource_packages 1
%global _debuginfo_subpackages 1
in /usr/lib/rpm/macros

The resulting debuginfo looked good.

I'm doing one more test with:
+#%undefine _unique_debug_names
+#%undefine _unique_debug_srcs

Because we don't really support multiple glibc debuginfo packages to be installed at the same time (though we could fix this in rawhide once we branch).

So I thought we better express this explicitly.
Comment 3 Carlos O'Donell 2017-07-27 09:19:59 EDT
Final scratch build before commit started.

Building glibc-2.25.90-28.fc27.src.rpm for rawhide
Created task: 20800498
Task info: https://koji.fedoraproject.org/koji/taskinfo?taskID=20800498
Comment 4 Carlos O'Donell 2017-07-27 12:42:21 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.