Bug 147501 - loki games don't run since 2.6.8
Summary: loki games don't run since 2.6.8
Status: CLOSED DUPLICATE of bug 147503
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-08 16:57 UTC by Jürgen Botz
Modified: 2015-01-04 22:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-08 23:26:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jürgen Botz 2005-02-08 16:57:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
loki games won't start since kernel 2.6.8, at least redhat kernel,
haven't tested vanilla kernel yet.  None of the following settings
(all of which have been suggeste for binary backward compatibility in
various places) seem to make a difference:

  export LD_ASSUME_KERNEL=2.4.19 {cmd}
  setarch i386 {cmd}
  sysctl -w kernel.exec-shield=0
  sysctl -w kernel.exec-shield-randomize=0
  sysctl -w vm.legacy_va_layout=1
  sysctl -w kernel.vdso=0

For example Loki's "Sid Meyer's Alpha Centauri" (smac) gives the
following (no change with any/all of the above:

[jbotz@tango smac]$ ./smac

BUG! (Segmentation Fault)  Going down hard...
Sid Meier's Alpha Centauri 6.0a
Built with glibc-2.1 on x86
Stack dump:
{
        0x837dcde
        0x835cc24
        0x835ca8b
        0x83568bd
        0x8356a3e
        0x834a4cf
        0x8341b89
        0x8341c68
        0x8297f4b
        0x842202d
        0x8048111
}
Please send a full bug report,
along with the contents of autosave to: support@lokigames.com
Unable to execute loki_qagent - exiting

This all continues to be true on FC3, and with all redhat kernels I've
tried since 2.6.8.



Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1. boot an FC2 system w/ kernel >= 2.6.8
2. run a loki games binary (i.e. 'smac')
3.
    

Additional info:

Comment 1 Dave Jones 2005-02-08 23:26:06 UTC
as fc2 and fc3 share the same kernel, I'm closing this as a dupe.


*** This bug has been marked as a duplicate of 147503 ***


Note You need to log in before you can comment on or make changes to this bug.