Bug 147502 - GATEWAYDEV not evaluated properly when using two eth's as dhcp clients
GATEWAYDEV not evaluated properly when using two eth's as dhcp clients
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: dhcp (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Popelka
RHEL3U7NAK
:
Depends On:
Blocks: 190430
  Show dependency treegraph
 
Reported: 2005-02-08 11:58 EST by Moritz Baumann
Modified: 2010-04-06 09:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-06 09:20:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Baumann 2005-02-08 11:58:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
we have two interfaces eth0 and eth1 which are both configured via
dhcp and are getting both a default gw via dhcp.

==========================
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:D0:B7:91:D8:B3
ONBOOT=yes
TYPE=Ethernet
============================
DEVICE=eth1
BOOTPROTO=dhcp
HWADDR=00:0E:0C:60:CF:15
ONBOOT=yes
TYPE=Ethernet 

It would be nice if GATEWAYDEV from /etc/sysconfig/network would be
evaluated.

As it is right now the default-gw from eth0 is always chosen.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:


Actual Results:  default route is chosen from the dhcp config sent by eth0

Expected Results:  evaluation of GATEWAYDEV /etc/sysconfig/network

so if I set GATEWAYDEV=eth1 I would expect that the default route send
via dhcp on eth1 would be chosen.

Additional info:

happens on Fedora Core 3 as well
Comment 1 Bill Nottingham 2005-02-08 12:22:36 EST
Does the patch in 133575 work for you?
Comment 2 Moritz Baumann 2005-02-10 05:10:00 EST
Unfortunately not. It only applies to BOOTPROTO=static and not to the
dynamic section.
Comment 3 Bill Nottingham 2005-02-10 16:30:42 EST
I do believe all the gateway setting is done in dhclient-script.
Comment 4 Jason Vas Dias 2005-02-10 18:00:11 EST
This problem will be fixed in the next DHCP version.
If GATEWAYDEV is set, and the interface being configured with DHCP
is not the GATEWAYDEV, then the default route will not be created
by the dhclient-script .
The new dhclient-script also deletes any current default route before
attempting to create a new one; the reason eth0's DHCP router option
was always used as the default was that eth1's dhclient-script 
session tried to create the default route, but it failed because
a default route already existed . For this reason, if GATEWAY is
set in /etc/sysconfig/network then no invocation of the new 
dhclient-script should attempt to create a default route. 
This fix will be in dhcp-3.0.1-11_EL3 shortly - I'll update this
bug when it is.
Comment 5 Jason Vas Dias 2005-02-11 19:45:27 EST
This bug is now fixed in dhcp-3.0.1-33_EL3, which is making its way
through QA and hopefully into RHEL-3-U5 . Meanwhile, you can download
it from:
   http://people.redhat.com/~jvdias/DHCP/RHEL-3/
Please test and let me know if it is OK or you have any problems.
Thanks, Jason Vas Dias, Red Hat .
Comment 6 Moritz Baumann 2005-02-17 09:52:33 EST
ok. now the behaviour is as follows:

both interfaces get their ips and a default gw via dhcp.

If GATEWAYDEV is set the default route is always set according to the
GATEWAYDEV (which is what we/most people will want).

If there is no GATEWAYDEV it seems that the default gateway of the
last (eth1) interface will be used. Whether it is always the last or
only the interface which gets quicker a dhcp response I have not
verified. But since there is nowhere a preference this behaviour
should be ok.
Comment 7 Jason Vas Dias 2005-02-17 11:10:00 EST
Yes, the previous behavior was that ONLY the first DHCP session to
set the default gateway could succeed; if you happened to want the
second session to succeed, you'd be out of luck. Now at least one
has some control over this with GATEWAYDEV. 
Interface devices are always brought up in the numerical order of
their interface number : eth0, eth1... etc. - and no interface 
configuration begins before the previous session ends . While 
dhclient is capable of configuring multiple interfaces in parallel,
this feature is not used .
Comment 8 Jason Vas Dias 2005-10-14 10:50:46 EDT
This bug is fixed with dhcp-3.0.1-40_EL3+
Comment 15 Jiri Popelka 2010-04-06 09:20:10 EDT
Closing as WONTFIX. dhcp-3.0.1-10_EL3 is the latest version shipped for RHEL-3.

Note You need to log in before you can comment on or make changes to this bug.