Bug 1475064 - Build KF5 QCH API documentation
Build KF5 QCH API documentation
Status: NEW
Product: Fedora
Classification: Fedora
Component: kf5 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 20:49 EDT by Kevin Kofler
Modified: 2017-07-25 20:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2017-07-25 20:49:55 EDT
Description of problem:
This really affects all the kf5-* packages and not the metapackage, but I am not feeling like filing a separate bug for each and every kf5-* package.

https://www.kde.org/announcements/kde-frameworks-5.36.0.php says:
> All frameworks: Option to build & install QCH file with the public API dox
This should be provided by Fedora packaging. The QCH API documentation can be used in KDevelop. In fact, I did not find ANY apidocs for the kf5-* packages I looked at, not even HTML ones, which is a regression compared to our kdelibs 4 packaging.

Version-Release number of selected component (if applicable):
kf5-*-5.36.0-1.fc*

Note You need to log in before you can comment on or make changes to this bug.