This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1475432 - Windows hosts losing IPv6 gateway acquired from radvd
Windows hosts losing IPv6 gateway acquired from radvd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: radvd (Show other bugs)
26
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Pavel Zhukov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 12:40 EDT by Pim Zandbergen
Modified: 2017-08-01 02:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 02:11:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pim Zandbergen 2017-07-26 12:40:08 EDT
Description of problem:

After upgrading Fedora Server 25 to Fedora Server 26, Windows hosts are randomly losing their IPv6 default gateway, some time after acquiring them from radvd. Restarting radvd does not fix this, but restarting the Windows host does. Shortly disconnecting the network cable too.

Windows hosts do not lose their IPv6 address. They remain reachable in the local subnet.

Windows hosts are logging an error in the system event log, with source tcpip:
Autoconfigured route limit has been reached. No further autoconfigured routes will be added until the interface is reconnected.

The time that this error is logged does not correspond to the loss of the gateway, however. Usually the gateway is lost before this error is logged.

This is affecting multiple versions of Windows, like Server 2008, Server 2008 R2, Server 2012, Server 2012 R2, Server 2016, Windows 7, Windows 10.

Non-Windows hosts do not seem to be affected (Linux, VMware vSphere).


Version-Release number of selected component (if applicable):
radvd-2.14-2.fc26.x86_64

How reproducible:
Randomly, but usually within 24 hours.


Steps to Reproduce:
1. upgrade to radvd-2.14-2.fc26.x86_64 from an earlier working setup
2. run ipconfig /all on Windows. Note the default gateway
3. 24 hours later, run it again. Look for an IPv6 LL address as default gateway
4. search for source "tcpip" in the system event log.

Actual results:
3. the IPv6 default gateway is gone, host unreachable from other subnets
4. the mentioned error message is logged, but not always

Expected results:
3. the IPv6 default gateway still present
4. no error message in the event log


Additional info:
/etc/radvd.conf
# main network
interface enp31s0f0
{
        AdvSendAdvert on;
        AdvDefaultPreference high;
        prefix xxxx:yyyy:zzzz:fff0::/64 {};
        RDNSS xxxx:yyyy:zzzz:fff0::1 {};
        DNSSL macroscoop.nl {};
};

# iSCSI
interface enp31s0f1
{
        AdvSendAdvert on;
        AdvDefaultLifetime 0;
        prefix xxxx:yyyy:zzzz:fff2::/64 {};
};
Comment 1 Pavel (pavlix) Šimerda 2017-07-26 15:35:28 EDT
This might be related to intrinsic problems in IPv6 auto configuration protocol specifications.

https://tools.ietf.org/html/draft-gont-6man-slaac-dns-config-issues-01
Comment 2 Pim Zandbergen 2017-07-31 13:32:37 EDT
It is known that Windows hosts ignore the RDNSS and DNSSL configuration.
This is not the issue.
The issue is with Windows hosts losing the route that radvd advertises.
And with Windows hosts complaining that "route limits" are being reached.

However, these errors have not been seen on our network for 5 days now,
without changing the radvd configuration.

Also, I have not been able to reproduce this problem on other similar
networks.

The fact that this problem started after upgrading to F26 might have
been a coincidence and may be unrelated.
Comment 3 Pavel Zhukov 2017-08-01 02:11:34 EDT
(In reply to Pim Zandbergen from comment #2)
> It is known that Windows hosts ignore the RDNSS and DNSSL configuration.
> This is not the issue.
> The issue is with Windows hosts losing the route that radvd advertises.
> And with Windows hosts complaining that "route limits" are being reached.
> 
> However, these errors have not been seen on our network for 5 days now,
> without changing the radvd configuration.
> 
> Also, I have not been able to reproduce this problem on other similar
> networks.
Hello,
Thank you for the information. 
Closing the bug for now. Please reopen if issue is back.
> 
> The fact that this problem started after upgrading to F26 might have
> been a coincidence and may be unrelated.

Note You need to log in before you can comment on or make changes to this bug.