Bug 1475492 - Display name of repo as seen from subscription manager
Display name of repo as seen from subscription manager
Status: CLOSED DUPLICATE of bug 1433023
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
Unspecified
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 15:07 EDT by roywilli
Modified: 2017-08-07 09:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-04 14:53:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description roywilli 2017-07-26 15:07:50 EDT
Description of problem:
Currently, there is no way to see how the name of a repo will appear via subscription manager in the UI.  Conversely, there is no way to locate a repo by the name described in install docs when adding new products to Satellite.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
On client system:
# subscription-manager repos
...

On satellite, the names listed here are not 1:1 with what is listed in the Satellite UI. (Content -> Products, nor Content -> Red Hat Repositories)

Actual results:
Desired value not found in product.

Expected results:
The name used by subscription manager should appear somewhere.  Ideally, it should be listed both on the Red Hat Repositories page, and in the details of repositories that are synchronized.

Additional info:
This would be very helpful, when writing automation to enable specific repos in post install.  Additionally, it would greatly simplify finding repos for other products based on the information provided in install docs.
Comment 1 Rich Jerrido 2017-07-26 15:36:30 EDT
Note: this information is stored in the subscription-manifest, so it is being delivered to Satellite today.
Comment 3 Brad Buckingham 2017-08-04 10:30:01 EDT
Hi, would this be a duplicate of bug 1433023?
Comment 4 roywilli 2017-08-04 14:30:53 EDT
Yes.  Good catch.
Comment 5 Brad Buckingham 2017-08-04 14:53:57 EDT

*** This bug has been marked as a duplicate of bug 1433023 ***

Note You need to log in before you can comment on or make changes to this bug.