Bug 147550 - gimp hangs upon selecting Save or Save As
gimp hangs upon selecting Save or Save As
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-02-09 00:59 EST by Trevor Cordes
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-16 07:23:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
installed rpms (14.31 KB, text/plain)
2005-02-10 13:45 EST, Trevor Cordes
no flags Details

  None (edit)
Description Trevor Cordes 2005-02-09 00:59:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I haven't used gimp since the last couple of errata updates.  I just
tried using it now and I cannot save a file.  Attempting to do so
hangs gimp and it must be killed.  This never happened with the older
FC3 version.

Just to make sure it wasn't my setup, I rpm -e'd the main gimp rpm's
and yum install'd, and I also rm -rf ~/.gimp* to create a whole new

Version-Release number of selected component (if applicable):
gimp-2.2.3-0.fc3.2 gimp-data-extras-1.2.0-12

How reproducible:

Steps to Reproduce:
1. run gimp
2. select file -> new
3. accept defaults
4. right-click menu on image -> Save As

Actual Results:  hangs

Expected Results:  save dialog should appear

Additional info:
Comment 1 Trevor Cordes 2005-02-09 03:45:21 EST
I should have added that I get the following error output when I kill
the process:

gimp: terminated: Terminated
/usr/lib/gimp/2.0/plug-ins/script-fu terminated: Terminated
Comment 2 Nils Philippsen 2005-02-09 08:38:47 EST
That message is expected if you kill the GIMP. Do you get any other messages?
Which version of gtk2 do you have? I've got the same versions of gimp,
gimp-data-extras and gtk2-2.4.14-2.fc3 and it works as expected.
Comment 3 Trevor Cordes 2005-02-09 19:43:48 EST
No other messages.  All my packages are fully up to date via yum.


Like I said, gimp was working great.  The last time I used it was 1-2 months ago. 
I think it must have been some recent update that ruined it.

The only thing that might be odd with my config is I'm not using a fresh FC3
install but instead an anaconda upgrade from FC2.
Comment 4 Nils Philippsen 2005-02-10 02:57:51 EST
Hmm, odd. If you could attach a file containing a list of your packages ("rpm
-qa") I could run a diff over it to what I have on my machines, perhaps this
sheds some light on the matter.
Comment 5 Trevor Cordes 2005-02-10 13:45:56 EST
Created attachment 110929 [details]
installed rpms
Comment 6 Trevor Cordes 2005-02-10 13:54:01 EST
One thing I just thought of that is also odd with my system... I've
updated the kernel a couple of times but not yet rebooted.  It's my
workstation and I have about 100 windows open and customized.  Boots
are a pain.  Based on my understanding of the kernel (and gimp!) this
should not cause a problem though?
Comment 7 Trevor Cordes 2005-02-15 09:31:02 EST
OK, I've had a chance to reboot my system and now it works 100% as expected. 
The "bug" was simply having updated too many rpm's without a reboot.  My guess
is it was the kernel rpm (modules issue?) that was to blame.  My kernel was
2.6.9-1.724_FC3 and I had since installed 741 (but not rebooted).  Right before
reboot I installed 2.6.10-1.766_FC3.  Now running 766 gimp works perfectly.

So who knows if you can call this a "bug".  Perhaps there is an (unwritten?)
rule that one should be rebooting immediately after a kernel update?  Strange,
but no other apps besides gimp (and I run a *lot* of stuff on this box) had any

At least this leaves a trail if anyone else ever runs into this obscure issue.
Comment 8 Adam Thompson 2005-02-15 22:49:45 EST
Of particular note: updating libc, glib* and gtk* RPMs and then trying to run
GTK applications before rebooting (or at least restarting X) has always been
problematic for me.  I used to have similar issues with KDE on older systems.
Basically, you wind up with two different versions of libgtk-whatever in memory
at once - and if, say, the internal API on some IPC call changed, you can get
random results if both old and new attempt to use (e.g.) the same block of
shared memory.
Comment 9 Nils Philippsen 2005-02-16 07:23:07 EST
Thanks for testing this out. I'm also not sure about what's the culprit (there
are more things that change when rebooting an updated system, i.e. all the
system daemons), but we might as well file this under "not repeatable" and be
done with it.

Note You need to log in before you can comment on or make changes to this bug.