Bug 1475543 - fedmsg-tail dies with SEGV
fedmsg-tail dies with SEGV
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: fedmsg (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Infrastructure SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 17:06 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2017-08-01 09:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 23:34:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2017-07-26 17:06:54 EDT
Description of problem:
$  fedmsg-tail --include 'org.fedoraproject.prod.buildsys' --terse
[1]    18314 segmentation fault (core dumped)  fedmsg-tail --include 'org.fedoraproject.prod.buildsys' --terse

Version-Release number of selected component (if applicable):
python2-fedmsg-commands-0.18.2-2.fc26.noarch
python2-2.7.13-11.fc26.x86_64

How reproducible:
100% on this machine.

Additional info:
Abrt submitted a trace, but said the traceback was unusuable
https://retrace.fedoraproject.org/faf/reports/1675132/, so I'm opening a bugzilla ticket manually.

Hmm, is this because both openssl-libs-1.1.0f-4.fc26.x86_64 and compat-openssl10-1.0.2j-6.fc26.x86_64 is linked into the same process? 

(gdb) bt 
#0  0x0000000100000000 in ?? ()
#1  0x00007f56bc66bc92 in X509_STORE_CTX_cleanup () from /lib64/libcrypto.so.10
#2  0x00007f56bc66bd3e in X509_STORE_CTX_free () from /lib64/libcrypto.so.10
#3  0x00007f56bcc55a01 in _wrap_x509_store_ctx_free (self=<optimized out>, args=<optimized out>) at SWIG/_m2crypto_wrap.c:22725
#4  0x00007f56ce680bce in call_function (oparg=<optimized out>, pp_stack=0x7ffeb04cf4b8) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4429
#5  PyEval_EvalFrameEx (f=f@entry=Frame 0x7f56b6d8a210, for file /usr/lib64/python2.7/site-packages/M2Crypto/X509.py, line 876, in __del__ (self=<X509_Store_Context(ctx=<SwigPyObject at remote 0x7f56b6d853c0>, _pyfree=1) at remote 0x7f56ba89aef0>), throwflag=throwflag@entry=0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3063
#6  0x00007f56ce681828 in PyEval_EvalCodeEx (co=<optimized out>, globals=<optimized out>, locals=<optimized out>, args=<optimized out>, argcount=<optimized out>, kws=0x0, kwcount=0, defs=0x0, defcount=0, closure=0x0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3661
#7  0x00007f56ce5c21ce in function_call.lto_priv () from /lib64/libpython2.7.so.1.0
#8  0x00007f56ce599ea3 in PyObject_Call () from /lib64/libpython2.7.so.1.0
#9  0x00007f56ce5e4e7e in instancemethod_call.lto_priv () from /lib64/libpython2.7.so.1.0
#10 0x00007f56ce599ea3 in PyObject_Call () from /lib64/libpython2.7.so.1.0
#11 0x00007f56ce677e97 in PyEval_CallObjectWithKeywords (func=<instancemethod at remote 0x7f56baf0d9b0>, arg=(), kw=<optimized out>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4298
#12 0x00007f56ce5d642b in instance_dealloc.lto_priv () from /lib64/libpython2.7.so.1.0
#13 0x00007f56ce5c47d7 in frame_dealloc.lto_priv () from /lib64/libpython2.7.so.1.0
#14 0x00007f56ce67f1e4 in fast_function (nk=<optimized out>, na=<optimized out>, n=<optimized out>, pp_stack=0x7ffeb04cfa98, func=<function at remote 0x7f56bc1c2d70>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4516
#15 call_function (oparg=<optimized out>, pp_stack=0x7ffeb04cfa98) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4449
#16 PyEval_EvalFrameEx (f=f@entry=Python Exception <class 'gdb.error'> There is no member named ob_ival.: 
, throwflag=throwflag@entry=0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3063
#17 0x00007f56ce681828 in PyEval_EvalCodeEx (co=<optimized out>, globals=<optimized out>, locals=<optimized out>, args=<optimized out>, argcount=<optimized out>, kws=0x55a08ea05518, kwcount=50, defs=0x7f56c3095128, defcount=1, closure=0x0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3661
#18 0x00007f56ce5c2367 in function_call.lto_priv () from /lib64/libpython2.7.so.1.0
#19 0x00007f56ce599ea3 in PyObject_Call () from /lib64/libpython2.7.so.1.0
#20 0x00007f56ce67d073 in ext_do_call (nk=<optimized out>, na=1, flags=<optimized out>, pp_stack=0x7ffeb04cfd20, func=<function at remote 0x7f56bc1c2de8>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4743
#21 PyEval_EvalFrameEx (f=f@entry=Frame 0x55a08ee70330, for file /usr/lib/python2.7/site-packages/fedmsg/crypto/__init__.py, line 256, in validate (message={u'username': u'apache', u'certificate': u'LS0tLS1CRUdJTiBDRVJUSUZJQ0FURS0tLS0tCk1JSUVTakNDQTdPZ0F3SUJBZ0lDQWRzd0RRWUpL\nb1pJaHZjTkFRRUZCUUF3Z2FBeEN6QUpCZ05WQkFZVEFsVlQKTVFzd0NRWURWUVFJRXdKT1F6RVFN\nQTRHQTFVRUJ4TUhVbUZzWldsbmFERVhNQlVHQTFVRUNoTU9SbVZrYjNKaApJRkJ5YjJwbFkzUXhE\nekFOQmdOVkJBc1RCbVpsWkcxelp6RVBNQTBHQTFVRUF4TUdabVZrYlhObk1ROHdEUVlEClZRUXBF\nd1ptWldSdGMyY3hKakFrQmdrcWhraUc5dzBCQ1FFV0YyRmtiV2x1UUdabFpHOXlZWEJ5YjJwbFkz\nUXUKYjNKbk1CNFhEVEUxTURFd05USXhNemd5TVZvWERUSTFNREV3TWpJeE16Z3lNVm93Z2RneEN6\nQUpCZ05WQkFZVApBbFZUTVFzd0NRWURWUVFJRXdKT1F6RVFNQTRHQTFVRUJ4TUhVbUZzWldsbmFE\nRVhNQlVHQTFVRUNoTU9SbVZrCmIzSmhJRkJ5YjJwbFkzUXhEekFOQmdOVkJBc1RCbVpsWkcxelp6\nRXJNQ2tHQTFVRUF4TWlhMjlxYVMxcmIycHAKTURFdWNHaDRNaTVtWldSdmNtRndjbTlxWldOMExt\nOXlaekVyTUNrR0ExVUVLUk1pYTI5cWFTMXJiMnBwTURFdQpjR2g0TWk1bVpXUnZjbUZ3Y205cVpX\nTjBMbTl5WnpFbU1DUUdDU3FHU0liM0RRRUpBUllYWVdSdGFXNUFabVZrCmIzSmhjSEp2YW1WamRD\nN...(truncated), throwflag=throwflag@entry=0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3102
#22 0x00007f56ce681828 in PyEval_EvalCodeEx (co=<optimized out>, globals=<optimized out>, locals=<optimized out>, args=<optimized out>, argcount=<optimized out>, kws=0x55a08ea03178, kwcount=49, defs=0x0, defcount=0, closure=0x0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3661
#23 0x00007f56ce5c2367 in function_call.lto_priv () from /lib64/libpython2.7.so.1.0
#24 0x00007f56ce599ea3 in PyObject_Call () from /lib64/libpython2.7.so.1.0
#25 0x00007f56ce67d073 in ext_do_call (nk=<optimized out>, na=1, flags=<optimized out>, pp_stack=0x7ffeb04cffa0, func=<function at remote 0x7f56bbb02488>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4743
#26 PyEval_EvalFrameEx (f=f@entry=Python Exception <class 'gdb.error'> There is no member named ob_ival.: 
, throwflag=throwflag@entry=0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3102
#27 0x00007f56ce681828 in PyEval_EvalCodeEx (co=<optimized out>, globals=<optimized out>, locals=<optimized out>, args=<optimized out>, argcount=<optimized out>, kws=0x55a08ee6a8a8, kwcount=0, defs=0x7f56bc1bf9e8, defcount=1, closure=0x0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3661
#28 0x00007f56ce67e863 in fast_function (nk=0, na=<optimized out>, n=<optimized out>, pp_stack=0x7ffeb04d0178, func=<function at remote 0x7f56bbb08140>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4524
#29 call_function (oparg=<optimized out>, pp_stack=0x7ffeb04d0178) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4449
#30 PyEval_EvalFrameEx (f=Python Exception <class 'gdb.error'> There is no member named ob_ival.: 
, throwflag=<optimized out>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3063
#31 0x00007f56ce6478eb in gen_send_ex.isra.0.lto_priv () from /lib64/libpython2.7.so.1.0
#32 0x00007f56ce67d64c in PyEval_EvalFrameEx (f=Python Exception <class 'gdb.error'> There is no member named ob_ival.: 
, throwflag=<optimized out>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:2882
#33 0x00007f56ce6478eb in gen_send_ex.isra.0.lto_priv () from /lib64/libpython2.7.so.1.0
#34 0x00007f56ce67d64c in PyEval_EvalFrameEx (f=Python Exception <class 'gdb.error'> There is no member named ob_ival.: 
, throwflag=<optimized out>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:2882
#35 0x00007f56ce6478eb in gen_send_ex.isra.0.lto_priv () from /lib64/libpython2.7.so.1.0
#36 0x00007f56ce67d64c in PyEval_EvalFrameEx (f=f@entry=Python Exception <class 'gdb.error'> There is no member named ob_ival.: 
, throwflag=throwflag@entry=0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:2882
#37 0x00007f56ce681828 in PyEval_EvalCodeEx (co=<optimized out>, globals=<optimized out>, locals=<optimized out>, args=<optimized out>, argcount=<optimized out>, kws=0x7f56bc205e88, kwcount=0, defs=0x0, defcount=0, closure=0x0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3661
#38 0x00007f56ce67e863 in fast_function (nk=0, na=<optimized out>, n=<optimized out>, pp_stack=0x7ffeb04d0778, func=<function at remote 0x7f56bba44b18>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4524
#39 call_function (oparg=<optimized out>, pp_stack=0x7ffeb04d0778) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4449
#40 PyEval_EvalFrameEx (f=f@entry=Python Exception <class 'gdb.error'> There is no member named ob_ival.: 
, throwflag=throwflag@entry=0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3063
#41 0x00007f56ce67f1c9 in fast_function (nk=<optimized out>, na=<optimized out>, n=1, pp_stack=0x7ffeb04d0898, func=<function at remote 0x7f56bbad4410>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4514
#42 call_function (oparg=<optimized out>, pp_stack=0x7ffeb04d0898) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4449
#43 PyEval_EvalFrameEx (f=f@entry=Python Exception <class 'gdb.error'> There is no member named ob_ival.: 
, throwflag=throwflag@entry=0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3063
#44 0x00007f56ce67f1c9 in fast_function (nk=<optimized out>, na=<optimized out>, n=0, pp_stack=0x7ffeb04d09b8, func=<function at remote 0x7f56bba425f0>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4514
#45 call_function (oparg=<optimized out>, pp_stack=0x7ffeb04d09b8) at /usr/src/debug/Python-2.7.13/Python/ceval.c:4449
#46 PyEval_EvalFrameEx (f=f@entry=Frame 0x7f56cea42cc8, for file /usr/bin/fedmsg-tail, line 11, in <module> (), throwflag=throwflag@entry=0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3063
#47 0x00007f56ce681828 in PyEval_EvalCodeEx (co=<optimized out>, globals=<optimized out>, locals=<optimized out>, args=<optimized out>, argcount=<optimized out>, kws=0x0, kwcount=0, defs=0x0, defcount=0, closure=0x0) at /usr/src/debug/Python-2.7.13/Python/ceval.c:3661
#48 0x00007f56ce681a39 in PyEval_EvalCode (co=<optimized out>, globals=<optimized out>, locals=<optimized out>) at /usr/src/debug/Python-2.7.13/Python/ceval.c:691
#49 0x00007f56ce65c47f in run_mod () from /lib64/libpython2.7.so.1.0
#50 0x00007f56ce65c52a in PyRun_FileExFlags () from /lib64/libpython2.7.so.1.0
#51 0x00007f56ce65d52e in PyRun_SimpleFileExFlags () from /lib64/libpython2.7.so.1.0
#52 0x00007f56ce64b0ae in Py_Main () from /lib64/libpython2.7.so.1.0
#53 0x00007f56cd8134da in __libc_start_main (main=0x55a08d4fc740 <main>, argc=5, argv=0x7ffeb04d0df8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffeb04d0de8) at ../csu/libc-start.c:295
#54 0x000055a08d4fc77a in _start ()
Comment 1 Kevin Fenzi 2017-07-31 19:40:12 EDT
Where do you see the two openssls? that could indeed cause problems... 

I am not seeing this here. ;( 

Do you have python2-fedmsg-meta-fedora-infrastructure installed?

Actually how about a 'rpm -qa | grep fedmsg | sort' ?
Comment 2 Zbigniew Jędrzejewski-Szmek 2017-07-31 23:34:07 EDT
I run dnf upgrade since then, and the problem seems to have gone away.
Comment 3 Jeremy Cline 2017-08-01 09:06:38 EDT
Cool. My guess is this is a problem with m2crypto. fedmsg-0.19 uses cryptography instead of m2crypto.

Note You need to log in before you can comment on or make changes to this bug.