Bug 147576 - oprofile crash with rawhide kernel
oprofile crash with rawhide kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: oprofile (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: William Cohen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-09 09:59 EST by Andrew Haley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 11:58:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Haley 2005-02-09 09:59:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Oprofile doesn't work at all.


Version-Release number of selected component (if applicable):
vmlinuz-2.6.10-1.1110_FC4

How reproducible:
Always

Steps to Reproduce:
     # cat /dev/oprofile/cpu_type 
Segmentation fault


Additional info:
  # cat /proc/cpuinfo 
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 5
model name      : AMD Opteron(tm) Processor 144

 # uname -a
Linux zapata.pink 2.6.10-1.1110_FC4 #1 Tue Jan 25 20:28:22 EST 2005
i686 athlon i386 GNU/Linux
Comment 1 Andrew Haley 2005-02-09 10:01:07 EST
oprofile-devel-0.8.1-11
oprofile-0.8.1-11
Comment 2 Andrew Haley 2005-02-09 10:06:17 EST
Here's the kernel trace:

 <1>Unable to handle kernel NULL pointer dereference at virtual
address 00000000
 printing eip:
f8aec419
*pde = 00000000
Oops: 0000 [#45]
DEBUG_PAGEALLOC
Modules linked in: oprofile md5 ipv6 parport_pc lp parport autofs4
sunrpc dm_mod video button battery ac ohci1394 ieee1394 ohci_hcd
ehci_hcd i2c_nforce2 i2c_core snd_intel8x0 snd_ac97_codec snd_pcm_oss
snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc 8139too
mii floppy ext3 jbd
CPU:    0
EIP:    0060:[<f8aec419>]    Not tainted VLI
EFLAGS: 00010246   (2.6.10-1.1110_FC4) 
EIP is at oprofilefs_str_to_user+0x17/0x36 [oprofile]
eax: 00000000   ebx: 00000000   ecx: ffffffff   edx: ffffffff
esi: 00001000   edi: 00000000   ebp: 095de950   esp: c54ccf6c
ds: 007b   es: 007b   ss: 0068
Process cat (pid: 29001, threadinfo=c54cc000 task=e00fda80)
Stack: 00000000 f8aefae0 d68bcf58 00001000 c54ccfac f8aec275 c54ccfac
c015fd4b 
       c54ccfac 095de950 d68bcf58 fffffff7 00001000 c54cc000 c015ffc0
c54ccfac 
       00000000 00000000 00000000 00000003 0804b38b c010338b 00000003
095de950 
Call Trace:
 [<f8aec275>] cpu_type_read+0xe/0x10 [oprofile]
 [<c015fd4b>] vfs_read+0xba/0x115
 [<c015ffc0>] sys_read+0x3c/0x62
 [<c010338b>] syscall_call+0x7/0xb
Code: 8b 53 58 89 43 4c 89 53 50 89 43 44 89 53 48 89 d8 5b 5e c3 55
89 d5 83 ca ff 57 89 c7 56 89 ce 89 d1 53 53 31 db 89 04 24 89 d8 <f2>
ae f7 d1 49 51 89 f2 89 e8 ff 74 24 04 8b 4c 24 20 e8 d7 92 
 
Comment 3 William Cohen 2005-02-09 10:57:19 EST
Unfortunately, I don't have 32-bit linux installed on a x86-64
machine, so I tried to replicate the problem on 64-bit version. I
installed the 64-bit 2.6.10-1.1110_FC4, rebooted the amd64 machine. 

$ uname -a
Linux dhcp59-190.rdu.redhat.com 2.6.10-1.1110_FC4 #1 Tue Jan 25
20:26:47 EST 2005 x86_64 x86_64 x86_64 GNU/Linux

$opcontrol --init
$ cat /dev/oprofile/cpu_type
x86-64/hammer

It didn't crash, so this problem seems to be limited to the 32-bit
kernels on x86-64 processors.

Is there the same problem reading out any of the other files in
/dev/oprofile?
Comment 4 Andrew Haley 2005-02-09 11:40:40 EST
zapata:/local/home/aph # cat /dev/oprofile/stats/cpu0/backtrace_aborted 
0
zapata:/local/home/aph # cat
/dev/oprofile/stats/cpu0/sample_lost_overflow 
0
zapata:/local/home/aph # cat /dev/oprofile/stats/cpu0/sample_received
     
0
zapata:/local/home/aph # cat /dev/oprofile/cpu_type 
Segmentation fault
zapata:/local/home/aph # cat /dev/oprofile/pointer_size 
4
zapata:/local/home/aph # cat /dev/oprofile/enable       
0

Comment 5 William Cohen 2005-02-09 11:58:57 EST
I was able to recreate this with vmlinuz-2.6.10-1.1110_FC4 with an
i686 install on the x86-64.

However, this problem does not appear on the 2.6.10-1.1134_FC4 version
of the kernel. Suggest moving to a newer rawhide kernel.
Comment 6 Andrew Haley 2005-02-10 07:53:34 EST
I can confirm that 2.6.10-1.1134_FC4 fixes the problem.

Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.