Bug 147583 - Cann't install libgda-1.2.0-1
Cann't install libgda-1.2.0-1
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libgda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-09 10:45 EST by sangu
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-17 08:32:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 167700 None None None Never

  None (edit)
Description sangu 2005-02-09 10:45:45 EST
Description of problem:
$rpm -ihv libgda-1.2.0-1.i386.rpm
error: Failed dependencies:
        libgda-2.so.1 is needed by libgda-1.2.0-1.i386
    Suggested resolutions:
        libgda-1.0.4-3.i386.rpm


Version-Release number of selected component (if applicable):
libgda-1.2.0-1

How reproducible:


Steps to Reproduce:
1. $rpm -ihv libgda-1.2.0-1.i386.rpm
2.
3.
  
Actual results:
always

Expected results:


Additional info:
Comment 1 scott white 2005-02-09 15:19:41 EST
same here with yum

# yum update libgda
Setting up Update Process
Setting up Repos
dev                       100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
dev       : ################################################## 3741/3741
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package libgda.i386 1:1.2.0-1 set to be updated
--> Running transaction check
--> Processing Dependency: libgda-2.so.1 for package: libgnomedb
--> Processing Dependency: libgda-2.so.1 for package: abiword
--> Processing Dependency: libgda-2.so.1 for package: libgda
--> Processing Dependency: libgda-2.so.1 for package: gnumeric
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package abiword.i386 1:2.2.3-3 set to be updated
---> Package libgnomedb.i386 1:1.2.0-1 set to be updated
---> Package gnumeric.i386 1:1.4.2-2 set to be updated
--> Running transaction check
--> Processing Dependency: libgda-2.so.1 for package: libgda
--> Finished Dependency Resolution
Error: Missing Dependency: libgda-2.so.1 is needed by package libgda
Comment 2 Michal Jaegermann 2005-02-09 19:02:51 EST
There is a weird dependency listed libgda-1.2.0-1.i386. 'rpm -qR ...'
for this package shows:
....
libgda-2.so.1  
libgda-2.so.3  
...
but the package itself provides only libgda-2.so.3.  Interestingly
enough the same package compiled for x86_64 has only
'libgda-2.so.3()(64bit)' listed in dependencies so there is no
obstacle there.

To get past that I had to 'rpm -Fvh --nodeps libgda-1.2.0-1.i386.rpm'
and then the rest installs fine. 'abiword', 'gnumeric' and
'libgnomedb' are currently updated and do need a new libgda.
Comment 3 Richard Henderson 2005-02-10 00:27:52 EST
The problem is that the package build rules are incorrect.
The file libgda-report-2.so.3 is linked against the *installed* version
of libgda-2.so, and not the *new* version.  Thus, while you can force the
package to install, you'll find

/usr/lib/libgda-report-2.so.3:
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x6ff58000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x6ff33000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x6ff0f000)
        libdl.so.2 => /lib/libdl.so.2 (0x6feeb000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x6fe33000)
        libxslt.so.1 => /usr/lib/libxslt.so.1 (0x6fddc000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0x6fc9a000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x6fc66000)
        libz.so.1 => /usr/lib/libz.so.1 (0x6fc33000)
        libm.so.6 => /lib/tls/libm.so.6 (0x6fb9d000)
        libgda-2.so.1 => not found
        libc.so.6 => /lib/tls/libc.so.6 (0x6fa40000)
        /lib/ld.so.1 (0x08000000)

Note the "not found" line.  Simply rebuilding the package would "work", but
would leave the build bug latent until the next time the version number gets
bumped.
Comment 4 Richard Henderson 2005-02-10 00:29:22 EST
Oh, and this isn't i386 specific.  I see the same problem with ppc.
Comment 5 Caolan McNamara 2005-02-10 03:20:41 EST
I'll add a bandaid for now.
Comment 6 Alexandre Oliva 2005-02-10 13:55:36 EST
AutoReqProv: no?!?  That breaks in that the package won't provide the
lib sonames that it should.
Comment 7 Alexandre Oliva 2005-02-10 13:56:11 EST
AutoReqProv: no?!?  That breaks in that the package won't provide the
lib sonames that it should.
Comment 8 Michal Jaegermann 2005-02-10 17:24:05 EST
It looks that that cure is worse then the disease.

Error: Missing Dependency: libgda-2.so.3()(64bit) is needed by package
abiword
Error: Missing Dependency: libgda-2.so.3()(64bit) is needed by package
gnumeric
Error: Missing Dependency: libgda-2.so.3()(64bit) is needed by package
libgnomedb

while libgda-2.so.3 is clearly there.  It this what Alexandre says
in a somehwat cryptic way in comments #6 and #7?

This time one needs 'rpm -Fvh --nodeps libgda*' everywhere. :-)


Note You need to log in before you can comment on or make changes to this bug.