Bug 1475843 - Volume quota making changes in CLI not replicating in GUI in RHOSP 10
Volume quota making changes in CLI not replicating in GUI in RHOSP 10
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
high Severity high
: Upstream M2
: 13.0 (Queens)
Assigned To: Radomir Dopieralski
Ido Ovadia
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 09:07 EDT by KOSAL RAJ I
Modified: 2018-01-16 08:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-16 08:52:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Volume quota in horizon dashborad (78.32 KB, image/png)
2017-07-27 09:07 EDT, KOSAL RAJ I
no flags Details

  None (edit)
Description KOSAL RAJ I 2017-07-27 09:07:42 EDT
Created attachment 1305359 [details]
Volume quota in horizon dashborad

Description of problem:
Volume quota making changes in CLI not replicating in GUI in RHOSP 10

Version-Release number of selected component (if applicable):
RHOSP 10

How reproducible:


Steps to Reproduce:
[root@dell-per510-4 ~(keystone_admin)]# openstack project list
+----------------------------------+----------+
| ID                               | Name     |
+----------------------------------+----------+
| 90c79227aee04c5889fca6b44a12c512 | demo     |
| bf0f929cc8794c0abf4cf194152641a7 | admin    |
| e6bfb6adb2f046ac97e9671db51d8472 | services |
+----------------------------------+----------+
[root@dell-per510-4 ~(keystone_admin)]# 
[root@dell-per510-4 ~(keystone_admin)]# 
[root@dell-per510-4 ~(keystone_admin)]# cinder quota-show demo
+----------------------+-------+
| Property             | Value |
+----------------------+-------+
| backup_gigabytes     | 1000  |
| backups              | 10    |
| gigabytes            | 1000  |
| gigabytes_iscsi      | -1    |
| per_volume_gigabytes | -1    |
| snapshots            | 10    |
| snapshots_iscsi      | -1    |
| volumes              | 10    |
| volumes_iscsi        | -1    |
+----------------------+-------+
[root@dell-per510-4 ~(keystone_admin)]# 
[root@dell-per510-4 ~(keystone_admin)]# 
[root@dell-per510-4 ~(keystone_admin)]# cinder quota-update --gigabytes 2000 demo
+----------------------+-------+
| Property             | Value |
+----------------------+-------+
| backup_gigabytes     | 1000  |
| backups              | 10    |
| gigabytes            | 2000  |
| gigabytes_iscsi      | -1    |
| per_volume_gigabytes | -1    |
| snapshots            | 10    |
| snapshots_iscsi      | -1    |
| volumes              | 10    |
| volumes_iscsi        | -1    |
+----------------------+-------+
[root@dell-per510-4 ~(keystone_admin)]# 
[root@dell-per510-4 ~(keystone_admin)]# 
[root@dell-per510-4 ~(keystone_admin)]# cinder quota-show demo
+----------------------+-------+
| Property             | Value |
+----------------------+-------+
| backup_gigabytes     | 1000  |
| backups              | 10    |
| gigabytes            | 2000  |
| gigabytes_iscsi      | -1    |
| per_volume_gigabytes | -1    |
| snapshots            | 10    |
| snapshots_iscsi      | -1    |
| volumes              | 10    |
| volumes_iscsi        | -1    |
+----------------------+-------+

Note: Horizon dashboard screenshot is attached.

Actual results:

volume quota made changes in CLI not replicating in horizon dashboard

Expected results:
volume quota made changes in CLI should replicate in horizon dashboard

Additional info:

Packages:

puppet-horizon-9.5.0-1.el7ost.noarch
python-django-horizon-10.0.3-6.el7ost.noarch
openstack-dashboard-10.0.3-6.el7ost.noarch
openstack-dashboard-theme-10.0.3-6.el7ost.noarch
Comment 4 Radomir Dopieralski 2018-01-16 08:52:59 EST
After some more investigation, this is a mistake in the commands used on the command line, not a bug in Horizon. The cinder command expects the tenant ID, not its name. So the correct commands would be:

cinder quota-show 90c79227aee04c5889fca6b44a12c512
cinder quota-update --gigabytes 2000 90c79227aee04c5889fca6b44a12c512

This shows and updates the quotas for the correct project, and the changes are immediately visible in Horizon.

Note You need to log in before you can comment on or make changes to this bug.