Bug 1475950 - Volume mounting problem using docker-latest and SELinux
Volume mounting problem using docker-latest and SELinux
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker-latest (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Frantisek Kluknavsky
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 11:34 EDT by Daniel Walsh
Modified: 2017-09-05 06:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: docker-latest-1.13.1-22.git28ae36d.el7_4
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 06:35:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Daniel Walsh 2017-07-27 11:37:00 EDT
Lokesh the latest docker-latest in projectatomic has a fix for this.
Comment 5 Luwen Su 2017-08-28 04:04:35 EDT
Shows fine in docker-latest-1.13.1-23.git28ae36d.el7.x86_64
#docker-latest volume create --driver local --opt type=nfs --opt o=addr=10.66.3.110,ro --opt device=:/mnt/ --name files

#docker-latest service create --name=test test

#docker-latest service update --mount-add type=volume,source=files,target=/mnt/ test
test
# echo $?
0
Comment 7 errata-xmlrpc 2017-09-05 06:35:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2598

Note You need to log in before you can comment on or make changes to this bug.