Bug 1475968 - Cannot update to boost packages due to missing dependencies
Cannot update to boost packages due to missing dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jonathan Wakely
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 12:15 EDT by David Hill
Modified: 2017-08-09 13:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 13:00:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hill 2017-07-27 12:15:25 EDT
Description of problem:
  - package libreoffice-filters-1:5.4.0.1-1.fc27.x86_64 requires libreoffice-calc(x86-64) = 1:5.4.0.1-1.fc27, but none of the providers can be installed
  - package libreoffice-calc-1:5.4.0.1-1.fc27.x86_64 requires libboost_filesystem.so.1.63.0()(64bit), but none of the providers can be installed
  - package libreoffice-filters-1:5.3.4.1-1.fc26.x86_64 requires libreoffice-draw(x86-64) = 1:5.3.4.1-1.fc26, but none of the providers can be installed
  - cannot install both boost-filesystem-1.64.0-0.2.fc27.x86_64 and boost-filesystem-1.63.0-9.fc27.x86_64
  - cannot install both boost-filesystem-1.63.0-5.fc26.x86_64 and boost-filesystem-1.64.0-0.2.fc27.x86_64
  - cannot install both libreoffice-draw-1:5.3.4.1-1.fc26.x86_64 and libreoffice-draw-1:5.4.0.1-1.fc27.x86_64
  - package liborcus-0.12.1-5.fc27.x86_64 requires libboost_filesystem.so.1.64.0()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package unoconv-0.7-5.fc26.noarch
  - cannot install the best update candidate for package libreoffice-draw-1:5.4.0.1-1.fc27.x86_64
  - cannot install the best update candidate for package liborcus-0.12.1-4.fc26.x86_64
 Problem 7: problem with installed package libreoffice-filters-1:5.4.0.1-1.fc27.x86_64
  - package libreoffice-filters-1:5.4.0.1-1.fc27.x86_64 requires libreoffice-calc(x86-64) = 1:5.4.0.1-1.fc27, but none of the providers can be installed
  - package libreoffice-calc-1:5.4.0.1-1.fc27.x86_64 requires libboost_filesystem.so.1.63.0()(64bit), but none of the providers can be installed
  - package boost-filesystem-1.63.0-9.fc27.x86_64 requires boost-system(x86-64) = 1.63.0-9.fc27, but none of the providers can be installed
  - package boost-filesystem-1.63.0-5.fc26.x86_64 requires boost-system(x86-64) = 1.63.0-5.fc26, but none of the providers can be installed
  - cannot install both boost-system-1.64.0-0.2.fc27.x86_64 and boost-system-1.63.0-9.fc27.x86_64
  - cannot install both boost-system-1.63.0-5.fc26.x86_64 and boost-system-1.64.0-0.2.fc27.x86_64
  - package boost-random-1.64.0-0.2.fc27.x86_64 requires libboost_system.so.1.64.0()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package boost-random-1.63.0-9.fc27.x86_64
 Problem 8: problem with installed package unoconv-0.7-5.fc26.noarch
  - package unoconv-0.7-5.fc26.noarch requires libreoffice-filters, but none of the providers can be installed
  - package libreoffice-filters-1:5.4.0.1-1.fc27.x86_64 requires libreoffice-calc(x86-64) = 1:5.4.0.1-1.fc27, but none of the providers can be installed
  - package libreoffice-calc-1:5.4.0.1-1.fc27.x86_64 requires libboost_filesystem.so.1.63.0()(64bit), but none of the providers can be installed
  - package boost-filesystem-1.63.0-9.fc27.x86_64 requires boost-system(x86-64) = 1.63.0-9.fc27, but none of the providers can be installed
  - package boost-filesystem-1.63.0-5.fc26.x86_64 requires boost-system(x86-64) = 1.63.0-5.fc26, but none of the providers can be installed
  - package libreoffice-filters-1:5.3.4.1-1.fc26.x86_64 requires libreoffice-graphicfilter(x86-64) = 1:5.3.4.1-1.fc26, but none of the providers can be installed
  - cannot install both boost-system-1.64.0-0.2.fc27.x86_64 and boost-system-1.63.0-9.fc27.x86_64
  - cannot install both boost-system-1.63.0-5.fc26.x86_64 and boost-system-1.64.0-0.2.fc27.x86_64
  - cannot install both libreoffice-graphicfilter-1:5.3.4.1-1.fc26.x86_64 and libreoffice-graphicfilter-1:5.4.0.1-1.fc27.x86_64
  - package boost-thread-1.64.0-0.2.fc27.x86_64 requires libboost_system.so.1.64.0()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package libreoffice-graphicfilter-1:5.4.0.1-1.fc27.x86_64
  - cannot install the best update candidate for package boost-thread-1.63.0-9.fc27.x86_64


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jonathan Wakely 2017-08-09 13:00:39 EDT
Those packages need to be rebuilt against the new Boost. If they failed to build then that's probably a bug in those packages.

Note You need to log in before you can comment on or make changes to this bug.