Bug 147598 - df reporting incorrect results; xfs_check error
df reporting incorrect results; xfs_check error
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xfsprogs (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-09 12:25 EST by Garrett Schure
Modified: 2013-07-02 22:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 14:56:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garrett Schure 2005-02-09 12:25:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
For an empty xfs filesytem, df is showing it as the wrong
size, and as far from empty:
  df -h /dev/sdb2
  Filesystem            Size  Used Avail Use% Mounted on
  /dev/sdb2             1.8G  1.2G  662M  64% /data/sgml

The mounted directory is correctly shown as empty by du:
  du -h /data/sgml
  0       /data/sgml

When I use xfs_check to investigate, it errors:
  xfs_check /dev/sdb2
  xfs_check: /dev/sdb2 contains a mounted and writable filesystem
  
  fatal error -- couldn't initialize XFS library


Version-Release number of selected component (if applicable):
xfsprogs-2.6.13-2

How reproducible:
Always

Steps to Reproduce:

    
Additional info:

I had very similar struggles getting the system installed,
with a similar setup, as reported in #122043, including
"system got mangled" during installation attempts, which
I also solved by getting rid of labels in my fstab.

There's a recent and similar du vs. df inconsistency post
on the linux-xfs list.  But the "couldn't initialize XFS
library" from xfs_check is *perhaps* fedora-installation
specific? 

I tried the voodoo of erase fsprogs, install fsprogs:
no help.
Comment 1 Robert Scheck 2006-06-25 13:20:34 EDT
Garrett, Fedora Core 3 is now maintained by the Fedora Legacy project
for security updates only. Does the problem still exist in a current
version of Fedora Core (e.g. Fedora Core 5 or Development tree)?

If yes, please change the version to match and try to provide further
information when possible. Otherwise please close the bug report...
Comment 2 Matthew Miller 2006-07-10 16:33:18 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 3 Eric Sandeen 2007-08-22 14:56:17 EDT
Closing this based on the ancient-ness of the report and no updates, and the
assumption that the system is no longer available for investigation.  I assume
this must be fixed by now; if you are still experiencing problems with recent
Fedora, please re-open with details and we'll work through it.

thanks,

-Eric

Note You need to log in before you can comment on or make changes to this bug.