Bug 147608 - yum crashes on update
yum crashes on update
Status: CLOSED DUPLICATE of bug 147124
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-09 14:51 EST by yeech
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yeech 2005-02-09 14:51:00 EST
Description of problem:
yum crashes on update 'yum update'. It seems to occur after trying
serveral mirrors.

Version-Release number of selected component (if applicable):
yum-2.1.13-1

How reproducible:
Infrequent

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
(32/61): libxklavier-1.14 100% |=========================|  75 kB   
00:00     
(33/61): glib2-devel-2.6. 100% |=========================| 1.4 MB   
00:08     
http://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/Fedora/RPMS/policycoreutils-1.21.12-2.i386.rpm:
[Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/policycoreutils-1.21.12-2.i386.rpm:
[Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
http://sunsite.mff.cuni.cz/pub/fedora/development/i386/Fedora/RPMS/policycoreutils-1.21.12-2.i386.rpm:
[Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
Traceback (most recent call last):
  File "/usr/bin/yum", line 7, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 146, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 630, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "__init__.py", line 442, in downloadPkgs
  File "repos.py", line 521, in get
  File "mirror.py", line 414, in urlgrab
  File "mirror.py", line 392, in _mirror_try
  File "mirror.py", line 290, in _get_mirror
IndexError: list index out of range


Expected results:


Additional info:
Comment 1 Seth Vidal 2005-02-09 16:09:47 EST

*** This bug has been marked as a duplicate of 147124 ***
Comment 2 mcbugzillaredhat 2005-03-15 14:06:21 EST
I just saw this bug with the current yum 2.2.0.  So _not_ RESOLVED.

Same triggering condition a observed previously - a package,
apparently missing from several mirrors, results in trying several
mirrors until boom.

Trying other mirror.
Traceback (most recent call last):
  File "/usr/bin/yum", line 7, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 146, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 640, in doTransaction
    problems = self.downloadPkgs(downloadpkgs)
  File "__init__.py", line 447, in downloadPkgs
  File "repos.py", line 527, in get
  File "mirror.py", line 414, in urlgrab
  File "mirror.py", line 392, in _mirror_try
  File "mirror.py", line 290, in _get_mirror
IndexError: list index out of range
Comment 3 Red Hat Bugzilla 2006-02-21 14:08:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.