Bug 147632 - Output of 'yum search' isn't very helpful
Output of 'yum search' isn't very helpful
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-09 17:52 EST by Peter Williams
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 17:58:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Williams 2005-02-09 17:52:04 EST
I think the output from the 'yum search' command could be improved to make it
more helpful. I have two main complaints:

* It's too verbose. Thanks to the package descriptions, very few packages fit on
a screenful of output. I don't think the package descriptions are helpful enough
(or at all) to warrant outputting them.

* I'm a little confused by the way that one package will show up several times
in  one search. I guess this is because if, say, an update for a package has
been issued, it exists in both the 'updates-released' and 'base' repositories,
as well as the virtual 'installed' repository. And if a package has been updated
multiple times, it looks like all versions are displayed. And a package will be
displayed twice if its name and description match.

I think the following changes should be made, at least to the default search mode:

* Only display package name, version, and repository
* If multiple packages with the same name, only display the newest
* Sort output by 'Installed' and 'Available'
* Possibly only match by package name, not description. Try 'yum search kernel',
eg. Maybe make this able to be turned on/off via a command-line switch.

So for instance something like:

$ yum search Omni
[data loading output]

Installed:
       Omni.i386             0.9.2-1.1      updates-released
       Omni-foomatic.i386    0.9.2-1.1      updates-released

Available:
       Omni-debuginfo.i386   0.9.2-1.1      updates-released

As opposed to the mess which that command produces on an FC3 system.
Comment 1 Peter Williams 2005-02-09 17:58:20 EST
On the other hand, maybe I'm a dumbass and should have read about 'yum list'. My
bad.

Note You need to log in before you can comment on or make changes to this bug.